Bug 1411363 - OpenShift subdomain shows "undefined" for domain name
Summary: OpenShift subdomain shows "undefined" for domain name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.1
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 1.1
Assignee: Dylan Murray
QA Contact: James Olin Oden
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 14:51 UTC by Tasos Papaioannou
Modified: 2017-02-28 01:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 01:43:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0335 0 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.1 2017-02-28 06:36:13 UTC

Description Tasos Papaioannou 2017-01-09 14:51:08 UTC
Description of problem:

When creating an OpenShift deployment, the OpenShift > Configuration tab shows ".undefined" as the domain name:

----
Set subdomain name for a wildcard entry to point to the OpenShift router.
*.[text entry].undefined
----

/var/log/foreman/production.log shows an internal server error when trying to call the hostgroups API:

----
2017-01-09 09:38:40 [app] [I] Started GET "/api/v21/hostgroups" for 10.10.58.64 at 2017-01-09 09:38:40 -0500
2017-01-09 09:38:40 [app] [I] Processing by Api::V21::HostgroupsController#index as JSON
2017-01-09 09:38:40 [app] [I]   Parameters: {"apiv"=>"v21", "hostgroup"=>{}}
2017-01-09 09:38:40 [app] [W] <NilClass> nil
2017-01-09 09:38:40 [app] [I]   Rendered api/v2/errors/standard_error.json.rabl within api/v2/layouts/error_layout (0.9ms)
2017-01-09 09:38:40 [app] [I] Completed 500 Internal Server Error in 28ms (Views: 1.8ms | ActiveRecord: 4.3ms)
----

Version-Release number of selected component (if applicable):

First seen in QCI-1.1-RHEL-7-20170105.t.0, which is the first iso based on Sat 6.2.6.

Also seen in QCI-1.1-RHEL-7-20170106.

How reproducible:

100%

Steps to Reproduce:
1.) Create an RHV + OpenShift deployment.
2.) See "undefined" as domain name on OpenShift > Configuration tab.

Actual results:

Incorrect domain name.

Expected results:

Correct domain name.

Additional info:

Comment 4 Dylan Murray 2017-01-11 14:35:51 UTC
https://github.com/fusor/foretello_api_v21/pull/20

Comment 5 Dylan Murray 2017-01-11 15:30:28 UTC
This fix is in QCI-1.1-RHEL-7-20170111.t.1.

Comment 6 Tasos Papaioannou 2017-01-11 16:26:32 UTC
I see the same behavior in QCI-1.1-RHEL-7-20170111.t.1. "undefined" shows in the web UI, and the internal server error appears in production.log.

Comment 7 Dylan Murray 2017-01-11 17:03:02 UTC
https://github.com/fusor/foretello_api_v21/pull/21

My mistake, added that extra attribute by accident.

Comment 9 James Olin Oden 2017-01-12 15:45:51 UTC
Compose:  QCI-1.1-RHEL-7-20170111.t.8

Comment 12 errata-xmlrpc 2017-02-28 01:43:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335


Note You need to log in before you can comment on or make changes to this bug.