Bug 141144 - snmpwalk affects the network stack
snmpwalk affects the network stack
Status: CLOSED DUPLICATE of bug 125432
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-snmp (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 11:41 EST by Brock Organ
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brock Organ 2004-11-29 11:41:36 EST
* RHEL3-U3 s390-as
* customer reported
* kernel-2.4.21-20.EL
* net-snmp-5.0.9-2.30E.6

> "snmpwalk -v1 -cpublic localhost host" times out when it gets to the
> network interface information.
> during this time, "ifconfig" and "netstat -i" will hang (stop
> responding).
>  
> here's the snmpwalk out put to the point that it "hangs".
>  
> # snmpwalk -v1 -cXXXXX localhost host
> HOST-RESOURCES-MIB::hrStorageSize.101 = INTEGER: 253548
> HOST-RESOURCES-MIB::hrStorageSize.102 = INTEGER: 0
> HOST-RESOURCES-MIB::hrStorageUsed.1 = INTEGER: 146972
> HOST-RESOURCES-MIB::hrStorageUsed.2 = INTEGER: 2930
> HOST-RESOURCES-MIB::hrStorageUsed.3 = INTEGER: 17474
> HOST-RESOURCES-MIB::hrStorageUsed.4 = INTEGER: 4487
> HOST-RESOURCES-MIB::hrStorageUsed.5 = INTEGER: 4178
> HOST-RESOURCES-MIB::hrStorageUsed.6 = INTEGER: 33768
> HOST-RESOURCES-MIB::hrStorageUsed.101 = INTEGER: 250208
> HOST-RESOURCES-MIB::hrStorageUsed.102 = INTEGER: 0
> HOST-RESOURCES-MIB::hrStorageAllocationFailures.1 = Counter32: 0
> HOST-RESOURCES-MIB::hrStorageAllocationFailures.2 = Counter32: 0
> HOST-RESOURCES-MIB::hrStorageAllocationFailures.3 = Counter32: 0
> HOST-RESOURCES-MIB::hrStorageAllocationFailures.4 = Counter32: 0
> HOST-RESOURCES-MIB::hrStorageAllocationFailures.5 = Counter32: 0
> HOST-RESOURCES-MIB::hrStorageAllocationFailures.6 = Counter32: 0
> HOST-RESOURCES-MIB::hrDeviceIndex.769 = INTEGER: 769
> Timeout: No Response from localhost
> 
> if i turn up the timeout (-t10), then i will get another line after 
> a long pause.
>  
> # snmpwalk -v1 -t10 -cpublic localhost host
> HOST-RESOURCES-MIB::hrDeviceIndex.1025 = INTEGER: 1025
> Timeout: No Response from localhost
> 
> if i run an "ifconfig" before the "Timeout" message, it will hang. 
> here is the process status info ...
> F S UID        PID  PPID  C PRI  NI ADDR    SZ WCHAN  STIME
> TTY          TIME CMD
> 0 D root     16668 16520  0  75   0    -   905 down   15:56 pts/2   
> 00:00:00 ifconfig
> 
> # uname -a
> Linux nclzs0001.marriott.com 2.4.21-20.EL #1 SMP Wed Aug 18 20:32:45
> EDT 2004 s390 s390 s390 GNU/Linux
>  
> i have tried different versions of net-snmp ...
> net-snmp-5.0.9-2.30E.6
> net-snmp-5.1.1-5
> net-snmp-5.2.rc3
>  

so, according to the customer, while running snmpwalk, the network
stack is not responsive, however, when the snmpwalk process is killed,
the network is back to normal ... (customer verified behavior using lo
interface as well as qdio based eth0 interface) ...
Comment 1 Radek Vokal 2004-12-01 08:42:17 EST
Very strange, reproduced here on kryten.z900. Will look at it closer ..
Comment 2 Radek Vokal 2004-12-02 02:34:46 EST
Has a same effect as accesing ip.ipAddrTable. 

*** This bug has been marked as a duplicate of 125432 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.