Bug 141148 - RHEL4 U2: "cdrom_pc_intr: The drive appears confused" messages running newburn
RHEL4 U2: "cdrom_pc_intr: The drive appears confused" messages running newburn
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 11:58 EST by Stuart Hayes
Modified: 2015-01-04 17:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-17 15:43:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages file from failing system (386.92 KB, text/plain)
2004-11-29 12:01 EST, Stuart Hayes
no flags Details
/proc/ide/hda/settings file contents (115.71 KB, image/jpeg)
2004-11-29 12:03 EST, Stuart Hayes
no flags Details
console on failing system (154.78 KB, image/jpeg)
2004-11-29 12:04 EST, Stuart Hayes
no flags Details

  None (edit)
Description Stuart Hayes 2004-11-29 11:58:54 EST
Description of problem:

System : PE2650 
BIOS : A20
H/W config : 2* 2.4 Ghz /533FSB/12GB 
memory /PERC3Di/PERC4DC/Intel1000MT/2*BCM570X/AIC-39160

While running the "newburn" system stress utility (from Cerberus), 
the following messages are flashing on console:

cdrom_pc_intr: The drive appears confused (ireason = 0x01)
cdrom_pc_intr, write: dev hda: flags = REQ_STARTED REQ_PC REQ_QUIET
sector 0, nr/cnr 0/0
bio 00000000, biotail 00000000, buffer 00000000, data 00000000, len
cdb: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
hda: cdrom_pc_intr: The drive appears confused (ireason = 0xd0)
cdrom_pc_intr: The drive appears confused (ireason = 0x01)
cdrom_pc_intr: The drive appears confused (ireason = 0x01)
(and so on...)

In spite of these messages, the CD-ROM drive is working fine. The CD 
drive was replaced with a new one to eliminate a chance of a hardware 
error.

We've also seen this message on a PE2600:

"hda: cdrom_pc_intr: The drive appears confused (ireason = 0x01)"
which printed several times, then this-
"hda: packet command error: status=0xd0 { Busy }"
"ide: failed opcode was 100"


It sounds like this may not happen on RHEL4 beta1.

I'll attach /var/log/messages, the console while running newburn, and 
the contents of /proc/ide/hda/settings.




Version-Release number of selected component (if applicable):


How reproducible: Every time


Steps to Reproduce:
1. Install and run "newburn" stress program
2. Watch screen for error messages
3.
  
Actual results:
we get error messages listed above

Expected results:
no error messages

Additional info:
Comment 1 Stuart Hayes 2004-11-29 12:01:16 EST
Created attachment 107555 [details]
messages file from failing system
Comment 2 Stuart Hayes 2004-11-29 12:03:00 EST
Created attachment 107556 [details]
/proc/ide/hda/settings file contents
Comment 3 Stuart Hayes 2004-11-29 12:04:11 EST
Created attachment 107557 [details]
console on failing system
Comment 4 Alan Cox 2004-11-29 16:05:08 EST
Does this occur with hal disabled ?
Comment 5 Stuart Hayes 2004-12-07 14:56:53 EST
It turns out that this isn't easy to reproduce.  I haven't actually 
been able to reproduce this myself at all--it was just reported to me 
after a couple of failures were seen.

...What is hal, though?  And, how do I disable it?  
Comment 6 Amit Bhutani 2005-01-25 16:00:14 EST
Changing the title to reflect the Update in which a fix for this 
issue has been committed (from RH) or being tracked for..
Comment 7 Stuart Hayes 2005-02-17 15:08:21 EST
You can close this issue.  We have closed it from this side, as we were unable 
to reproduce it.
Thanks,
Stuart
Comment 8 Jason Baron 2005-02-17 15:43:27 EST
thanks. closing.

Note You need to log in before you can comment on or make changes to this bug.