Bug 1411667 - [RFE] populate all the free or available disks in the host when user tries to create a gluster brick from cockpit UI
Summary: [RFE] populate all the free or available disks in the host when user tries t...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: ---
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.4.0
: ---
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 09:18 UTC by RamaKasturi
Modified: 2019-04-22 07:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-22 07:00:13 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.4?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 74509 0 master MERGED WIP:gluster:show disk list in bricks tab 2017-04-19 12:41:20 UTC

Description RamaKasturi 2017-01-10 09:18:51 UTC
Description of problem:
As of today user has to specify the disk name with which he would like to create a brick. populate all the available/free disks in the hosts so that user can select the disk to create a brick.

Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.10.7-0.0.2.el7ev.noarch

How reproducible:


Steps to Reproduce:
1. Install cockpit-ovirt-dashboard
2. Now login to cockpit UI
3. select gluster and provide the host details.
4. click on next tab.

Actual results:
I see that for creating bricks user has to provide the disk names.

Expected results:
populate all the available/free disks so that user can choose the disk to create a brick instead of typing manually.

Additional info:

Comment 1 Fabian Deutsch 2017-01-12 07:33:52 UTC
Note: On Node - and probably on regular hosts as well - / is not considered to contain data.

If you need space, then please look to either use /var/* - because /var is considered to contain data.

Also: On Node it will even be a bad bug if you put data on /.

Comment 2 Sandro Bonazzola 2017-01-12 09:00:45 UTC
(In reply to Fabian Deutsch from comment #1)
> Note: On Node - and probably on regular hosts as well - / is not considered
> to contain data.
> 
> If you need space, then please look to either use /var/* - because /var is
> considered to contain data.
> 
> Also: On Node it will even be a bad bug if you put data on /.

I guess intention wasn't to suggest /, but to populate the list with all "available or free" disks

Comment 3 Ramesh N 2017-01-12 09:04:17 UTC
(In reply to Sandro Bonazzola from comment #2)
> (In reply to Fabian Deutsch from comment #1)
> > Note: On Node - and probably on regular hosts as well - / is not considered
> > to contain data.
> > 
> > If you need space, then please look to either use /var/* - because /var is
> > considered to contain data.
> > 
> > Also: On Node it will even be a bad bug if you put data on /.
> 
> I guess intention wasn't to suggest /, but to populate the list with all
> "available or free" disks

Yes. I am working with cockpit team to populate the list of free disks using storaged APIs.

Comment 5 Sandro Bonazzola 2019-01-28 09:42:05 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 6 Gobinda Das 2019-04-22 07:00:13 UTC
Now we don't have any plan to take this up as there are some challanges from cockpit side and it needs some times. Closing this for now, will reopen once will have solution.


Note You need to log in before you can comment on or make changes to this bug.