Bug 14121 - Record Locking through ncpmount/ncpfs
Record Locking through ncpmount/ncpfs
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ncpfs (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-17 12:17 EDT by Need Real Name
Modified: 2015-03-04 20:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-22 09:24:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-07-17 12:17:17 EDT
I am evaluating the connectivity of RedHat 6.2 to a Novell 4.11.  I am 
comparing the functionality with a SCO OS 5.0.5.  I believe there is a 
problem with record locking of files through the ncpmount gateway to the 
server.

The test I perform is as follows:

1 I am using FoxPro from a Windows 95 PC to open a database on the Novell 
server and then start to edit a record.  The record becomes locked.  To 
prove this, I try to access the same record from another instance of 
FoxPro and FoxPro reports that the record is locked.

2 If, while FoxPro has the record locked, I try to submit an update of the 
same record from a user program on the SCO machine the program blocks 
until I complete the edit at the Windows PC.

If I try the same operations but using the Linux machine to edit the 
database then the program runs to completion regardless of the fact that 
the FoxPro has locked the record.

I can demonstrate this through a PCAnyWhere session if you would like to 
see what I am doing.

Kevin Hambleton
Comment 1 Phil Knirsch 2001-10-22 09:24:07 EDT
Could you check if this problem persists with the newest Red Hat Linux release?
I assume it does though.

Also it would be good to know if you use the same ncpmount application on SCO as
on Linux (meaning of there is a special SCO software to do the netware volume
mounting).

If this is the case then it will prove to be very difficult to fix this problem
as it is likely to be a very inheritant ncpfs problem for which there is no
'easy' fix and should probably be really fixed in the long run by the real
maintainer.

Read ya, Phil
Comment 2 Phil Knirsch 2002-01-17 05:32:34 EST
As i got no response to my request for more testing i'm closing this bug as a
'WONTFIX' as i can't reproduce it myself and i belive it's more a real package
maintainer fix that would be required.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.