Bug 1412154 - SQL error on registering host to Satellite
Summary: SQL error on registering host to Satellite
Keywords:
Status: CLOSED DUPLICATE of bug 1405085
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Subscription Management
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 12:08 UTC by Roman Plevka
Modified: 2017-01-12 20:46 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-12 20:46:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Roman Plevka 2017-01-11 12:08:50 UTC
Description of problem:
I'm unable to find a proper reproducer, but this occurs quite often in our automation:

#on a host:
subscription-manager register --org AIQhkL --activationkey rIHOo7GNHP --force
ERROR:  current transaction is aborted, commands ignored until end of transaction block

foreman production log reveals the problematic statement:

2017-01-06 16:44:17 [foreman-tasks/action] [E] PG::Error: ERROR:  current transaction is aborted, commands ignored until end of transaction block
 | : SELECT  "fact_names".* FROM "fact_names"  WHERE "fact_names"."type" IN ('Katello::RhsmFactName') AND "fact_names"."name" = 'dmi'  ORDER BY fact_names.name LIMIT 1 (ActiveRecord::StatementInvalid)
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/postgresql_adapter.rb:822:in `exec'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/postgresql_adapter.rb:822:in `block in exec_no_cache'
...
(will attach the foreman-debug logs)

Version-Release number of selected component (if applicable):
sat6.2.7 snap#1

How reproducible:
not clear but happens during host registration

Actual results:
SELECT  "fact_names".* FROM "fact_names"  WHERE "fact_names"."type" IN ('Katello::RhsmFactName') AND "fact_names"."name" = 'dmi'  ORDER BY fact_names.name LIMIT 1 (ActiveRecord::StatementInvalid)

Expected results:
registration just works

Comment 3 Roman Plevka 2017-01-12 20:46:56 UTC

*** This bug has been marked as a duplicate of bug 1405085 ***


Note You need to log in before you can comment on or make changes to this bug.