Bug 1412176 - Incorrect URL for polling heat stack
Summary: Incorrect URL for polling heat stack
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 12.0 (Pike)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks: 1538214
TreeView+ depends on / blocked
 
Reported: 2017-01-11 13:12 UTC by Jan Provaznik
Modified: 2019-03-13 09:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1538214 (view as bug list)
Environment:
Last Closed: 2019-03-13 09:00:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1707619 0 None None None 2017-07-31 10:35:47 UTC
OpenStack gerrit 517596 0 None None None 2017-11-03 10:13:41 UTC

Description Jan Provaznik 2017-01-11 13:12:14 UTC
Description of problem:
There is a "topology" tab in the Horizon page which shows heat stack details (Project -> Orchestration -> Stacks -> stack_name). It shows stack's resource dependencies graph. Horizon polls for stack changes every few seconds
 (https://github.com/openstack/horizon/blob/stable/newton/horizon/static/horizon/js/horizon.heattop.js#L185)

The problem is that these pool requests fail with following error in apache log:
10.36.5.160 - - [11/Jan/2017:04:51:07 -0500] "GET /project/stacks/get_d3_data/30cbbd0b-8f90-422a-92db-54b77e547920/ HTTP/1.1" 404 262 "http://intel-canoepass-10.lab.bos.redhat.com/dashboard/
project/stacks/stack/30cbbd0b-8f90-422a-92db-54b77e547920/" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0"

So it seems it tries to use "/project/stacks/get_d3_data/" instead of "/dashboard/project/stacks/get_d3_data/". Which is probably because we define /dashboard base url in horizon httpd config file and horizon code has hardcoded "/project/stacks" path:
https://github.com/openstack/horizon/blob/stable/newton/horizon/static/horizon/js/horizon.heattop.js#L259

Version-Release number of selected component (if applicable):
python-django-horizon-10.0.1-4.el7ost.noarch
(this was on packstack deployment but python-django-horizon rpm and httpd configuration are same in Overcloud deployed by OSP Director)

Actual results:
Stack topology graph is not auto-refreshed

Expected results:
Stack topology graph is being refresshed

Comment 1 Thierry Vignaud 2017-10-31 07:46:57 UTC
This patch is still not on the stable/pike branch

Comment 3 Beth White 2017-11-03 10:13:41 UTC
backporting to stable/pike

Comment 4 Jon Schlueter 2017-11-14 20:36:05 UTC
Merge upstream stable/pike


Note You need to log in before you can comment on or make changes to this bug.