Bug 1412555 - Kickstartable Tree is not sorted by version on webui wizzard
Summary: Kickstartable Tree is not sorted by version on webui wizzard
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On:
Blocks: 1340444
TreeView+ depends on / blocked
 
Reported: 2017-01-12 09:45 UTC by Pavel Studeník
Modified: 2017-06-21 12:17 UTC (History)
2 users (show)

Fixed In Version: spacewalk-java-2.5.14-46-sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 12:17:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Studeník 2017-01-12 09:45:08 UTC
Description of problem:
It is regression because if I looked at Satellite  5.7 I saw sorted kickstart tree on create new profile page. I guess that reason is that kickstart tree is not syncing from cdn by version. Choice of some version of kickstart tree it is not clearly.

<option value="5">ks-rhel-x86_64-server-6-6.8</option>
<option value="6">ks-rhel-x86_64-server-6-6.6</option>
<option value="8">ks-rhel-x86_64-server-6-6.3</option>
<option value="9">ks-rhel-x86_64-server-6-6.1</option>
<option value="10">ks-rhel-x86_64-server-6-6.4</option>
<option value="11">ks-rhel-x86_64-server-6-6.2</option>
<option value="12">ks-rhel-x86_64-server-6-6.5</option></select>

page: /rhn/kickstart/CreateProfileWizard.do

(on uploading kickstart page it is sorted correct /rhn/kickstart/AdvancedModeCreate.do)

Version-Release number of selected component (if applicable):
spacewalk-java-2.5.14-42.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. got to page for creating new kickstart profile
2. look at list of kickstart tree

Actual results:
list is NOT sorted

Expected results:
list is sorted by version

Comment 2 Grant Gainey 2017-01-13 20:58:28 UTC
There are a number of named-hibernate-queries for getting lists-of-kickstart-trees, and they are ordered by label, or last_modified, or not-ordered, seemingly at random. Standardized all of them on 'order by k.label'

spacewalk.github:
5dfcd63a7cc986e8898733441ab519499819cd51

Comment 4 Pavel Studeník 2017-01-24 12:57:26 UTC
Verified spacewalk-java-2.5.14-46.el6sat.noarch

check pages:
 * /rhn/kickstart/KickstartSoftwareEdit.do
 * /rhn/kickstart/CreateProfileWizard.do
 * /rhn/kickstart/AdvancedModeCreate.do


Note You need to log in before you can comment on or make changes to this bug.