Bug 1412619 - RHEVH 3.6: autoinstall failed due rhn_autoinstall script
Summary: RHEVH 3.6: autoinstall failed due rhn_autoinstall script
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ovirt-3.6.10
: ---
Assignee: Douglas Schilling Landgraf
QA Contact: cshao
URL:
Whiteboard:
Keywords: AutomationBlocker, Regression, ZStream
: 1413373 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 12:58 UTC by Tareq Alayan
Modified: 2017-01-23 15:46 UTC (History)
15 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-01-23 14:07:25 UTC


Attachments (Terms of Use)
logs (62.76 KB, application/x-gzip)
2017-01-12 12:58 UTC, Tareq Alayan
no flags Details
screenshot (225.18 KB, image/png)
2017-01-12 14:26 UTC, Tareq Alayan
no flags Details
/var/log/*.*; /tmp (45.44 KB, application/x-gzip)
2017-01-13 06:05 UTC, cshao
no flags Details
auto57-all-log (78.44 KB, application/x-gzip)
2017-01-16 09:20 UTC, cshao
no flags Details
auto608-all-log (77.89 KB, application/x-gzip)
2017-01-16 09:20 UTC, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0185 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6.10 2017-01-24 17:55:58 UTC
oVirt gerrit 70162 master MERGED rhn: Add environment into rhn missing bits 2017-01-12 22:01 UTC
oVirt gerrit 70176 ovirt-3.6 POST rhn: Add environment into rhn missing bits 2017-01-12 22:01 UTC

Description Tareq Alayan 2017-01-12 12:58:06 UTC
Created attachment 1239902 [details]
logs

Description of problem:
Installation failed because vdsm is not stating, and it fails on ssh timeout  

Version-Release number of selected component (if applicable):
rhevm-3.6.10.2-0.2.el6.noarch
Red Hat Enterprise Virtualization Hypervisor release 7.3 (20170110.1.el7ev)
vdsm-4.17.37-1.el7ev.noarch

How reproducible:
always

Steps to Reproduce:
1. add host to engine 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaniv Kaul 2017-01-12 13:59:44 UTC
Have you looked why VDSM is not starting?

Comment 2 Tareq Alayan 2017-01-12 14:26:00 UTC
There is no VDSM logs at all.
when trying to systemctl start vdsm -l nothing happens. 

I saw hooks failures in the installation process, not sure if related (screenshot attached)

Comment 3 Tareq Alayan 2017-01-12 14:26 UTC
Created attachment 1239955 [details]
screenshot

Comment 4 Douglas Schilling Landgraf 2017-01-12 15:23:28 UTC
I have reproduced the report, investigating.

Comment 5 Douglas Schilling Landgraf 2017-01-12 22:07:45 UTC
Just to clarify, from my tests it's not about VDSM. This is report was caused because when we fixed the sat6.2 support we added a new entry "Environment" and autoinstall required the change too.

Comment 6 Red Hat Bugzilla Rules Engine 2017-01-12 22:07:51 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 7 cshao 2017-01-13 03:45:05 UTC
QE can reproduce this issue.

Test version:
rhev-hypervisor7-7.3-20170110.1.iso 

Test steps:
1. Auto install RHEV-H with rhn_auto parameters.
BOOTIF=xxx storage_init=/dev/sda adminpw=xxx rhn_username=xxx rhn_password=xxx rhn_url=xxx rhn_ca_cert=xxx firstboot.


Test result:
Auto install failed.
there is not enough arguments given for <function update at> of <ovirt.node.setup.rhn.rhn_model.RHN> object at xxx.

Comment 10 cshao 2017-01-13 06:05 UTC
Created attachment 1240217 [details]
/var/log/*.*; /tmp

Comment 12 Douglas Schilling Landgraf 2017-01-15 03:02:57 UTC
I will check the logs and see if rhn auto install was working as well in the past.

Comment 13 Nelly Credi 2017-01-15 14:04:34 UTC
*** Bug 1413373 has been marked as a duplicate of this bug. ***

Comment 14 Gil Klein 2017-01-15 14:09:58 UTC
Raising priority due to the automation impact

Comment 19 cshao 2017-01-16 09:20 UTC
Created attachment 1241156 [details]
auto57-all-log

Comment 20 cshao 2017-01-16 09:20 UTC
Created attachment 1241157 [details]
auto608-all-log

Comment 24 cshao 2017-01-22 05:37:22 UTC
Verify this bug according #c21 & 22


Note You need to log in before you can comment on or make changes to this bug.