Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1412884 - SELinux is preventing iwconfig from 'write' accesses on the file /run/tlp/lock_tlp.
Summary: SELinux is preventing iwconfig from 'write' accesses on the file /run/tlp/loc...
Keywords:
Status: CLOSED DUPLICATE of bug 1458014
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b32da7b64d3cd442402588708c0...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 03:59 UTC by Biji
Modified: 2017-06-10 16:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-10 16:06:30 UTC
Type: ---


Attachments (Terms of Use)

Description Biji 2017-01-13 03:59:01 UTC
Description of problem:
SELinux is preventing iwconfig from 'write' accesses on the file /run/tlp/lock_tlp.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that iwconfig should be allowed write access on the lock_tlp file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'iwconfig' --raw | audit2allow -M my-iwconfig
# semodule -X 300 -i my-iwconfig.pp

Additional Information:
Source Context                system_u:system_r:ifconfig_t:s0-s0:c0.c1023
Target Context                system_u:object_r:tlp_var_run_t:s0
Target Objects                /run/tlp/lock_tlp [ file ]
Source                        iwconfig
Source Path                   iwconfig
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-225.6.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.10.0-0.rc3.git1.2.fc26.x86_64 #1
                              SMP Tue Jan 10 16:20:14 UTC 2017 x86_64 x86_64
Alert Count                   3
First Seen                    2017-01-12 23:47:42 WIB
Last Seen                     2017-01-13 10:25:26 WIB
Local ID                      72c910da-aee5-44a7-97e1-f9a407d69233

Raw Audit Messages
type=AVC msg=audit(1484277926.579:345): avc:  denied  { write } for  pid=24709 comm="ethtool" path="/run/tlp/lock_tlp" dev="tmpfs" ino=25976 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tlp_var_run_t:s0 tclass=file permissive=0


Hash: iwconfig,ifconfig_t,tlp_var_run_t,file,write

Version-Release number of selected component:
selinux-policy-3.13.1-225.6.fc25.noarch

Additional info:
reporter:       libreport-2.8.0
hashmarkername: setroubleshoot
kernel:         4.10.0-0.rc3.git1.2.fc26.x86_64
type:           libreport

Comment 1 Yamin 2017-06-10 16:06:30 UTC

*** This bug has been marked as a duplicate of bug 1458014 ***


Note You need to log in before you can comment on or make changes to this bug.