Bug 141289 - up2date returns 404 for kernel source
up2date returns 404 for kernel source
Status: CLOSED DUPLICATE of bug 141901
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 23:08 EST by Bobby Tharrington
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 12:17:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Hack to make up2date --get-source work in fc3 (4.52 KB, patch)
2005-01-29 17:31 EST, Oleg Makarenko
no flags Details | Diff

  None (edit)
Description Bobby Tharrington 2004-11-29 23:08:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
[root@webdev-laptop1 up2date]# up2date --get-source kernel
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-3
using mirror: http://gd.tuwien.ac.at/opsys/linux/fedora/core/3/i386/os/
http://fedora.redhat.com/download/up2date-mirrors/updates-released-fc3
using mirror:
http://mirror.switch.ch/ftp/mirror/fedora/linux/core/updates/3/i386

Fetching all package list for channel: fedora-core-3...
########################################

Fetching all package list for channel: updates-released-fc3...
########################################

Fetching package list for channel: fedora-core-3...

Fetching
http://gd.tuwien.ac.at/opsys/linux/fedora/core/3/i386/os//headers/header.info...
########################################

Fetching package list for channel: updates-released-fc3...

Fetching
http://mirror.switch.ch/ftp/mirror/fedora/linux/core/updates/3/i386/headers/header.info...
########################################

kernel-2.6.9-1.681_FC3.src.rpm...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1248, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 714, in main
    return getPackages(pkgNames, source=1)
  File "/usr/sbin/up2date", line 1065, in getPackages
    onlySource = source)
  File "/usr/share/rhn/up2date_client/up2date.py", line 196, in getPackage
    progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 335, in doCall
    raise up2dateErrors.CommunicationError(msg)
up2date_client.up2dateErrors.CommunicationError: Error communicating
with server. The message was:

An HTTP error occurred:
URL:
http://mirror.switch.ch/ftp/mirror/fedora/linux/core/updates/3/i386/SRPMS/kernel-2.6.9-1.681_FC3.src.rpm
Status Code: 404
Error Message: Not Found



Version-Release number of selected component (if applicable):
up2date-4.3.47-5

How reproducible:
Always

Steps to Reproduce:
1.run up2date --get-source kernel
2.
3.
    

Actual Results:  404 error returned

Also, a 0 size rpm is created in the spool directory.  You have to
delete the 0 size src.rpm to reproduce the error (otherwise, no error
is reported but the file remains a 0 size):

[root@webdev-laptop1 up2date]# ls -l /var/spool/up2date/kernel*
-rw-------  1 root root 772357 Nov 29 10:53
/var/spool/up2date/kernel-2.6.9-1.681_FC3.i686.hdr
-rw-r--r--  1 root root      0 Nov 29 10:57
/var/spool/up2date/kernel-2.6.9-1.681_FC3.src.rpm


Additional info:
Comment 1 John Reiser 2004-12-07 14:50:09 EST
Note that the http 404 error can be explained by the
".../i386/SRPMS/..." in the pathname.  It should be ".../SRPMS/..."
without the "/i386"; that is, --get-source must remove the trailing
$ARCH before adding "/SRPMS".  So, a manual workaround is to use
'wget' or 'curl' on a copy-and-edit pathname.
Comment 2 Oleg Makarenko 2005-01-29 13:44:58 EST
It is also not possible to use --get-source for any other package.

If you enable the retrieveSource=1 in /etc/sysconfig/rhn/up2date then
up2date stops on every package as it is unable to download source files. 

So retrieveSource doesn't work in FC3.

wget and curl may be used as a workaround for ad hoc source packages
downloads but not on a regular basis.

Comment 3 Oleg Makarenko 2005-01-29 13:53:54 EST
seems to be duplicate of 141459
Comment 4 Oleg Makarenko 2005-01-29 17:31:59 EST
Created attachment 110402 [details]
Hack to make up2date --get-source work in fc3

Actually you can't get SRPMS for any updated package. There is no SRPMS
directory in .../updates/3/i386/ where up2date tries to find the source
package:

url = "%s/SRPMS/%s" % (channel[url], filename)

Fedora Core 2 and 1 do have SRPMS directory so this line works fine. 

Looks like a problem with repository. Is it that difficult to add a link to
.../updates/3/SRPMS?

As a workaround I have hacked up2date to accept one more optional parameter for
SRPMS relative path.

See the patch for details.
Comment 5 Steven D. Harris 2005-04-29 15:01:23 EDT
this is a duplicate of assigned bug #141901, only this bug report has a HACK to
patch the problem (see comment #4 from Oleg).
Comment 6 Rahul Sundaram 2005-06-27 12:17:14 EDT

*** This bug has been marked as a duplicate of 141901 ***

Note You need to log in before you can comment on or make changes to this bug.