Bug 141295 - (radeon DRI SMP) deadlock
(radeon DRI SMP) deadlock
Status: CLOSED DUPLICATE of bug 152648
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 01:35 EST by Jason Wilson
Modified: 2015-01-04 17:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-17 23:05:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Wilson 2004-11-30 01:35:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Machine install and operates fine without using SMP.
Boots fine with SMP enabled, but then hangs soon after - usually
during login to Gnome.
System logs do not report any particular messages before hang.

Problem also occured with kernel-smp-2.6.9-1.667 - same symptons.

Have tried booting with acpi=off and apm=off - no difference.



Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot with SMP kernel
2. Attept to login to Gnome
3.
    

Actual Results:  Complete system hang - requires holding power down
for 4 seconds to turn off.

Expected Results:  Doesn't hang.

Additional info:

lspci output (and others) can be added if of assistance
Comment 1 Jason Wilson 2004-11-30 22:24:16 EST
Using the following as a guide:
  http://www.fedorazine.com/content/view/13/
Have added noacpi and nofirewire with the same results.
Comment 2 Joe Cavanaugh 2004-12-03 11:21:36 EST
I have the same problem on a p4s800 motherboard.
Comment 3 Dave Jones 2005-01-14 02:23:52 EST
any improvement with the latest updates ?
Comment 4 Jason Wilson 2005-04-10 18:25:29 EDT
Have tried a few iterations.

Currently testing with 2.6.10-1.770_FC3 and still get hangs when attempting to
login.

Have tried various combinations of:
  noacpi
  apci=off
  nofirewire

System works fine with UP kernel.
Comment 5 Warren Togami 2005-04-10 18:28:59 EDT
http://people.redhat.com/davej/kernels/Fedora/FC3/RPMS.kernel/
Try the 2.6.11 based FC3 kernel from either fc3 updates testing or the above
URL.  Be sure to install all FC3 updates before booting this kernel.  Any better?
Comment 6 Jason Wilson 2005-04-10 20:39:39 EDT
Installed new kernel (already had updates installed) and same problem.

A colleague suggested turning off DRI in the xorg.conf file and this resolved
the issue.

Can now boot with 2.6.10-1.770_FC3 or kernel-smp-2.6.11-1.14_FC3 and everything
works fine.

Also removed the 'noacpi apci=off' from boot messages and system works with both
kernels.

If I put back the 'Load "dri"' module and restart X the system hangs on login again.

The system has a 'ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]' card
builtin.
Search through freedesktop.org did not indicate any known issues.

Some sort of conflict between the radeon driver and smp kernels?
Comment 7 Warren Togami 2005-04-10 20:47:54 EDT
Entirely possible.  Thank you for isolating this problem.  If you want to help
us work toward a solution, I would suggest next trying to isolate if the problem
is kernel, xorg-x11.  This may be very difficult because it is entirely likely
that the problem is a combination of the two.  radeon DRI has never been perfect.

You could try things like
1) build an upstream kernel.org kernel based on the /boot/config-VERSION config
file.  You can try plain 2.6.11.7, 2.6.12-rc2 or 2.6.12-rc2-mm2.  Read their
changelogs to see if anything related to DRI changed.
2) Search upstream freedesktop.org bugzilla and mailing lists.
3) Submit this bug to xorg's bugzilla where more people will see it.
 
Meanwhile do you really need 3D acceleration on your desktop?  If not then DRI
disabled is fine.  Just periodically try versions with DRI enabled to see if it
is ever fixed.
Comment 8 Mark Schreiber 2005-04-16 20:43:50 EDT
Note that this bug is similar to (and potentially even a duplicate of) Bug
#152648, which includes a link to working (though presumably not well-tested) RPMs.
Comment 9 Jason Wilson 2005-04-17 21:27:18 EDT
This does in fact appear to be a duplicate of Bug #152648.
System hangs resolved by installing suggested RPM's, but now 3D graphics fail
totally. See other bug for further details.

(I could not see how I can mark this as a duplicate)
Comment 10 Warren Togami 2005-04-17 23:05:26 EDT

*** This bug has been marked as a duplicate of 152648 ***

Note You need to log in before you can comment on or make changes to this bug.