Bug 1412978 - DNF groupinstall groupremove sanity
Summary: DNF groupinstall groupremove sanity
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 10:17 UTC by Michal Schorm
Modified: 2017-01-16 12:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 12:31:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Schorm 2017-01-13 10:17:13 UTC
Hello, please check, if this is *really* expected behaviour.
If yes, feel free to close it or move to the propper component.


What I did:
 * Running in Fedora 25 - Cinnamon
 * dnf groupinstall gnome
 * dnf groupremove gnome


Results:
 * screensaver - gone
 * terminal - gone (that was insidious!)
 * some keyboard shortcuts - unreactive
 * Cinnamon start locking with 2 different lockscreens (you unlock one and second appears)


Why does that happen: (no research done, just a thought)
 * Cinnamon is based on the Gnome and much from the settings is same or simmilar.       
 * Also, many similar tools can obsolete their twins.


Fix
 * If it is expected, i would at least add warning, that groupinstall may be dangerous, here:
   https://fedoraproject.org/wiki/Switching_Desktop_Environments

Comment 1 Jaroslav Mracek 2017-01-16 12:31:00 UTC
The problem is in Anaconda, because it doesn't mark any group or env. group as a installed. The problem will be solved with fc26 for new system installation.
In your case you can fix it, if you will installed again your primary used env. group. In your case "dnf group install 'Cinnamon Desktop'". After that you can install other groups without fear, that your primary env. group or their component will be removed. Hope, that it will help.

Comment 2 Michal Schorm 2017-01-16 12:39:18 UTC
Thanks for explanation.


Note You need to log in before you can comment on or make changes to this bug.