Bug 1413037 - Scheduler doesn't consider the old node which was removed and added by scaleup playbook for scheduling a pod.
Summary: Scheduler doesn't consider the old node which was removed and added by scaleu...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Avesh Agarwal
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 12:55 UTC by Miheer Salunke
Modified: 2020-02-14 18:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-26 20:43:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Miheer Salunke 2017-01-13 12:59:19 UTC
Description of problem:

The issue was that node991 which existed earlier was deleted by oc delete node...then entry was made in the inventory file under [new node] section for node991 and then scaleup.yaml playbook was run...adding the node991 was done by the playbook as we could see node991  in oc get nodes o/p with "Ready" status which means it is schedulable.....but when we schedule a pod on node991 using a nodeselector of node991 then we see the pod goes in pending state because of this [0] where you can see node 991 is not present....case ->https://access.redhat.com/support/cases/#/case/01764010  

[0]->

      FirstSeen     LastSeen        Count   From                    SubobjectPath   Type            Reason                  Message
      ---------     --------        -----   ----                    -------------   --------        ------                  -------
      12d           1h              10      {default-scheduler }                    Warning         FailedScheduling        pod (logging-es-546wrcu2-2-i0qvc) failed to fit in any node
    fit failure on node (node990.example.com): MatchNodeSelector
    fit failure on node (node930.example.com): CheckServiceAffinity
    fit failure on node (node931.example.com): CheckServiceAffinity
    fit failure on node (node992.example.com): MatchNodeSelector



Version-Release number of selected component (if applicable):
OCP 3.3.0

How reproducible:
Customer side

Steps to Reproduce:
  - oc delete node
  - reinstall os ond deleted node
  - scaleup playbook

Actual results:
The scheduler doesn't consider node991 for scheduling the pod.

Expected results:
The scheduler shall consider node991 for scheduling the pod.

Additional info:

Comment 2 Miheer Salunke 2017-01-13 12:59:54 UTC
Also the setup has 2 masters and 3 etcd servers.


Note You need to log in before you can comment on or make changes to this bug.