Bug 1413089 - is it possible to deny local libvirt's guest access to the Internet
Summary: is it possible to deny local libvirt's guest access to the Internet
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.3
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: yalzhang@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 15:25 UTC by lejeczek
Modified: 2017-01-19 12:45 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-19 10:29:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description lejeczek 2017-01-13 15:25:34 UTC
Description of problem:

Have a libvirt(own dhcp) with network in forward=route mode on a box directly connected to the internet with masquerade, all on the same one box.

I failed to block/ban traffic between a guest & the Internet. I've tried rich & direct.

It is either libvirt that puts it's rules that high up or firewalld not having _direct going in as first and foremost, or both libvirt and firewalld having it wrong?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Thomas Woerner 2017-01-17 16:36:28 UTC
Yes, libvirt is pushing it's own rules in the beginning, there is not a lot that firewalld could do here. This needs to be addressed in libvirt.

Reassigning to libvirt.

Comment 3 Daniel Berrangé 2017-01-17 16:42:31 UTC
If you're trying to control access for guests, then you should not be using firewalld directly, instead use libvirt's network filter facility which lets you attach filtering rules to guest virtual NICs. This is documented here http://libvirt.org/formatnwfilter.html

Comment 4 Jaroslav Suchanek 2017-01-19 10:29:55 UTC
I cannot see a bug to be fixed. I would recommend using the libvirt-users mailing list for general questions like this one. Thank you.

Comment 5 lejeczek 2017-01-19 12:45:01 UTC
fist of all it should be in man pages - we should not have to (first) go to any mailing list. Is it there?

I would hope - this would not be pipe's dream - that libvirt one day could give us a nicely formated & comprehensive man pages, maybe something what systemd & firewall does - libvirtd.formatfilter, etc. - users/admins should not have to sroogle, man pages is (should always be) the place.

Secondly, I filed it as firewall's problem - which to me was (possibly a bug) because it is unable to control the traffic between VM guest and the rest (Internet in my case).


Note You need to log in before you can comment on or make changes to this bug.