Bug 141311 - Attaching PNG image gives DBD error
Summary: Attaching PNG image gives DBD error
Status: CLOSED RAWHIDE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 2.18
Hardware: All Linux
high
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: Mike MacKenzie
URL: https://bugzilla.redhat.com/beta/show...
Whiteboard:
Keywords:
Depends On:
Blocks: BZ_218_Final
TreeView+ depends on / blocked
 
Reported: 2004-11-30 10:33 UTC by Nils Philippsen
Modified: 2007-03-27 04:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 09:57:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils Philippsen 2004-11-30 10:33:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0 StumbleUpon/1.998

Description of problem:
When trying to attach an image to the bug mentioned above, I see an error page:

"""
Software error:

DBD::Pg::st execute failed: ERROR:  attachments_attach_id_seq.currval is not yet defined in this session [for Statement "SELECT currval('attachments_attach_id_seq')"] at Bugzilla/DB.pm line 74
	Bugzilla::DB::SendSQL('SELECT currval(\'attachments_attach_id_seq\')') called at /var/www/bugzilla/beta/attachment.cgi line 888
	main::insert('\x{89}PNG\x{d}\x{a}\x{1a}\x{a}\x{0}\x{0}\x{0}\x{d}IHDR\x{0}\x{0}\x{6}\x{84}\x{0}\x{0}\x{4}\x{e}\x{8}\x{6}\x{0}\x{0}\x{0}\x{f2}\x{95}ZI\x{0}\x{0}\x{0}\x{4}sBIT\x{8}\x{8}\x{8}\x{8}|\x{8}d\x{88}\x{0}\x{0} \x{0}IDATx\x{9c}\x{ec}\x{bd}...') called at /var/www/bugzilla/beta/attachment.cgi line 125

For help, please send mail to the webmaster (bugzilla@redhat.com), giving this error message and the time and date of the error. 
"""

Time and Date is 2004-11-30, 11:30+01

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select "Create a New Attachment"
2. Choose a PNG image from disk
3. Select image/png as content type
4. Click on "Submit"
  

Actual Results:  Error message, no image attached to the bug

Expected Results:  No error message, image should have been attached to the bug

Additional info:

Comment 1 Nils Philippsen 2004-11-30 10:34:10 UTC
Well the bug id mentioned below actually (in URL:), it is

https://bugzilla.redhat.com/beta/show_bug.cgi?id=141309

Comment 2 David Lawrence 2004-12-11 03:14:34 UTC
This works for me currently and may have been fixed in the code area by some
other improvements I have made recently. Can you try to reattach the image or
other png to this report and close if it now works for you?


Comment 3 Nils Philippsen 2004-12-13 12:39:08 UTC
I tried to attach the image to the bug mentioned in comment #1 but to no avail:

Software error:

DBD::Pg::st execute failed: ERROR:  attachments_attach_id_seq.currval is not yet
defined in this session [for Statement "SELECT
currval('attachments_attach_id_seq')"] at Bugzilla/DB.pm line 74
	Bugzilla::DB::SendSQL('SELECT currval(\'attachments_attach_id_seq\')') called
at /var/www/bugzilla/beta/attachment.cgi line 888
	main::insert('\x{89}PNG\x{d}\x{a}\x{1a}\x{a}\x{0}\x{0}\x{0}\x{d}IHDR\x{0}\x{0}\x{6}\x{84}\x{0}\x{0}\x{4}\x{e}\x{8}\x{6}\x{0}\x{0}\x{0}\x{f2}\x{95}ZI\x{0}\x{0}\x{0}\x{4}sBIT\x{8}\x{8}\x{8}\x{8}|\x{8}d\x{88}\x{0}\x{0}
\x{0}IDATx\x{9c}\x{ec}\x{bd}...') called at
/var/www/bugzilla/beta/attachment.cgi line 125

For help, please send mail to the webmaster (bugzilla@redhat.com), giving this
error message and the time and date of the error. 

Comment 4 David Lawrence 2005-02-23 07:48:36 UTC
Please verify that this is no longer occuring with latest code and close if
satisfactory.

Comment 5 Nils Philippsen 2005-02-23 09:57:20 UTC
Works now, thanks!


Note You need to log in before you can comment on or make changes to this bug.