Bug 1413118 - Misleading error message when trying to install a rpm a second time
Summary: Misleading error message when trying to install a rpm a second time
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-software
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 16:56 UTC by Oliver Ilian
Modified: 2019-06-13 15:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-13 15:54:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
Example of error message when attempting to install a package that is already installed. (7.45 KB, image/png)
2017-01-13 17:00 UTC, Mark Thacker
no flags Details

Description Oliver Ilian 2017-01-13 16:56:05 UTC
Description of problem:
When a user tries to install a software that is already installed via Firefox (click on the rpm and choose "Software Installer", the error message says: "Sorry this did not work. Installation of xxx RPM failed". 

Version-Release number of selected component (if applicable):
gnome-software-3.14.7-2.el7.x86_64

Steps to Reproduce:
1. Install a RPM via Firefox
2. Try to install the same RPM a second time
3. 

Actual results:
Error message does not say that the package is already installed, but only gives an error.

Expected results:
Error message should state that the package is already installed.

Comment 1 Mark Thacker 2017-01-13 17:00:48 UTC
Created attachment 1240432 [details]
Example of error message when attempting to install a package that is already installed.

The attachment shows the misleading error message when attempting to install a package that is already up to date on the system.

Comment 3 amit yadav 2018-05-22 11:10:26 UTC
@Richard,

The issue is still reproducible with gnome-software-3.22.7-5.el7.x86_64 available in RHEL7.5. I tried in on my test vm and able to reproduce it easily. 

If you need any further details or logs let me know.


Note You need to log in before you can comment on or make changes to this bug.