Bug 1413195 - When attempting to install I get a traceback from anaconda
Summary: When attempting to install I get a traceback from anaconda
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.0.6
: 4.0
Assignee: Yuval Turgeman
QA Contact: Qin Yuan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 21:39 UTC by Michael
Modified: 2017-01-18 07:55 UTC (History)
9 users (show)

Fixed In Version: ovirt-node-ng-installer-ovirt-4.0-2017011712.iso
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 07:21:58 UTC
oVirt Team: Node
rule-engine: ovirt-4.0.z?
ycui: testing_ack?


Attachments (Terms of Use)
Screenshot of error (688.61 KB, image/jpeg)
2017-01-13 21:39 UTC, Michael
no flags Details
anaconda.log (639 bytes, text/plain)
2017-01-13 21:40 UTC, Michael
no flags Details
syslog (392.78 KB, text/plain)
2017-01-13 21:40 UTC, Michael
no flags Details
program.log (879 bytes, text/plain)
2017-01-13 21:41 UTC, Michael
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 70172 0 None None None 2017-01-16 19:56:29 UTC

Description Michael 2017-01-13 21:39:46 UTC
Created attachment 1240518 [details]
Screenshot of error

Description of problem:
When attempting to install I get a traceback from anaconda

Version-Release number of selected component (if applicable):
ovirt-node-ng-installer-ovirt-4.0-2017011115

How reproducible:
Every boot

Steps to Reproduce:
1. Burn ISO
2. Boot off of ISO (UEFI or non-UEFI)

Actual results:
See screenshot

Expected results:
Install prompt

Additional info:
Will attach logs from /tmp

Comment 1 Michael 2017-01-13 21:40:37 UTC
Created attachment 1240519 [details]
anaconda.log

Comment 2 Michael 2017-01-13 21:40:54 UTC
Created attachment 1240520 [details]
syslog

Comment 3 Michael 2017-01-13 21:41:10 UTC
Created attachment 1240521 [details]
program.log

Comment 4 Douglas Schilling Landgraf 2017-01-16 15:36:55 UTC
Thanks Michael for your report. Looks like it's anaconda/python-blivet issue, adding David into this report.

Comment 5 Sandro Bonazzola 2017-01-17 09:09:13 UTC
Ryan, is this included in any build we released? 4.0.7 is not built yet.

Comment 6 Ryan Barry 2017-01-17 15:06:40 UTC
No -- wrong dropdown.

We should definitely push a fixed ISO for 4.0.6 upstream, though. No version bump is necessary, just publishing a recent successful Jenkins build

Comment 7 Sandro Bonazzola 2017-01-18 07:55:00 UTC
Released ovirt-node-ng-installer-ovirt-4.0-2017011712.iso with the fix


Note You need to log in before you can comment on or make changes to this bug.