Bug 1413196 - RHEL OSP 8 to OSP 9 Official Upgrade Doc Missing inclusion of "--force-postconfig" required for Aodh Endpoint Creation
Summary: RHEL OSP 8 to OSP 9 Official Upgrade Doc Missing inclusion of "--force-postco...
Keywords:
Status: CLOSED DUPLICATE of bug 1377475
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 9.0 (Mitaka)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: RHOS Documentation Team
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 21:44 UTC by Chris Paquin
Modified: 2017-01-16 15:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 15:13:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chris Paquin 2017-01-13 21:44:23 UTC
Description of problem:

Section "3.4.2. Installing Aodh" of https://access.redhat.com/documentation/en/red-hat-openstack-platform/9/single/upgrading-red-hat-openstack-platform

does not include instructions to include "--force-postconfig" option required to create new endpoints for Aodh. This step includes calling 'e major-upgrade-aodh.yaml.

There is no mention of "--force-postconfig" anywhere in the documentation. 

Without this option endpoints are not created, Aodh will not start. Deploy will fail.



Version-Release number of selected component (if applicable):
8.0


How reproducible:
Follow OSP 8 to 9 Upgrade Guide

Steps to Reproduce:
1. Attempt to upgrade OSP 8 to OSP 9 following official doc
2. Include major-upgrade-aodh.yaml
3. Install fails

Actual results:
Upgrade fails during deployment

Expected results:
Deployment including major-upgrade-aodh.yaml completes without issue

Additional info:
See https://bugzilla.redhat.com//show_bug.cgi?id=1371580

Comment 1 Chris Paquin 2017-01-16 15:13:10 UTC
Dupe of https://bugzilla.redhat.com//show_bug.cgi?id=1377475

*** This bug has been marked as a duplicate of bug 1377475 ***


Note You need to log in before you can comment on or make changes to this bug.