Bug 1413252 - Move tmpfiles.d config to %{_tmpfilesdir}, install COPYING as %license
Summary: Move tmpfiles.d config to %{_tmpfilesdir}, install COPYING as %license
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pam_ssh
Version: rawhide
Hardware: All
OS: All
unspecified
unspecified
Target Milestone: ---
Assignee: Dmitry Butskoy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-14 07:19 UTC by Ville Skyttä
Modified: 2017-01-15 07:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-14 21:47:11 UTC
Type: ---


Attachments (Terms of Use)
Move tmpfiles.d config to %{_tmpfilesdir}, install COPYING as %license (1.72 KB, patch)
2017-01-14 07:19 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2017-01-14 07:19:04 UTC
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d#Example_spec_file

'git am'able fix attached, let me know if you'd like me to push and build this for devel.

Comment 1 Ville Skyttä 2017-01-14 07:19:09 UTC
Created attachment 1240615 [details]
Move tmpfiles.d config to %{_tmpfilesdir}, install COPYING as %license

Comment 2 Dmitry Butskoy 2017-01-14 21:47:11 UTC
...and "BuildRequires: systemd-units"  required :)

Thanks, done.

Comment 3 Ville Skyttä 2017-01-15 07:08:40 UTC
(In reply to Dmitry Butskoy from comment #2)
> ...and "BuildRequires: systemd-units"  required :)

My mock test builds complete fine without that. Besides, the macro definition is in the systemd package, not systemd-units:

# grep _tmpfilesdir /usr/lib/rpm/macros.d/macros.systemd
%_tmpfilesdir /usr/lib/tmpfiles.d
# rpm -qf /usr/lib/rpm/macros.d/macros.systemd 
systemd-232-6.fc26.x86_64

If there is a missing build dependency related to the use of %{_tmpfilesdir} in the Wiki's example specfile, could you file a FPC ticket about it? I could do that, but I cannot reproduce the missing build dep.

Comment 4 Ville Skyttä 2017-01-15 07:14:26 UTC
Nevermind, I managed to reproduce, and found that systemd provides systemd-units. FPC ticket filed: https://fedorahosted.org/fpc/ticket/670


Note You need to log in before you can comment on or make changes to this bug.