Bug 1413334 - Mate crashes sometimes when firefox displays a new page
Summary: Mate crashes sometimes when firefox displays a new page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-15 01:48 UTC by James
Modified: 2017-02-14 05:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-14 05:17:37 UTC
Type: Bug


Attachments (Terms of Use)
.xsession-errors.old (2.27 KB, text/plain)
2017-01-15 01:48 UTC, James
no flags Details
Modified 'dnf history info' output from 1/13 (1.82 KB, text/plain)
2017-01-15 01:49 UTC, James
no flags Details

Description James 2017-01-15 01:48:02 UTC
Created attachment 1240855 [details]
.xsession-errors.old

Description of problem: Mate crashes(along with all user processes) after certain pages loads in firefox. I don't know exactly what the page characteristics are that cause it but it doesn't happen until the page is actually displayed. If I open in a new tab the crash does not occur until I select that tab. I think this is a GTK issue as it only started happening after I pulled an update yesterday.


Version-Release number of selected component (if applicable):

gtk-update-icon-cache-3.22.6-2.fc25.x86_64
gtk3-3.22.6-2.fc25.x86_64
firefox-50.1.0-1.fc25.x86_64
mate-desktop-1.16.1-2.fc25.x86_64                               

How reproducible:


Steps to Reproduce:
1. Login to mate desktop
2. Start firefox
3. Click on a link to a problem webpage

Actual results:
Page displayed

Expected results:
Mate crashes and login screen is shown


Additional info:
While I can't generate this on demand, when it does happen it will consistently reproduce after logging in again and restarting firefox. Opening up the page from the restore session feature and clicking the link will cause Mate to reliably crash.

This shows up in .xsession-errors.old:
Gdk-Message: mate-terminal: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

This only started happening after an update around 5:00pm eastern on 1/13. Attached is the list of package updates.

Comment 1 James 2017-01-15 01:49:34 UTC
Created attachment 1240856 [details]
Modified 'dnf history info' output from 1/13

Comment 2 James 2017-01-15 01:59:20 UTC
It seems I can reproduce this behavior right here on bugzilla with this link:

https://bugzilla.redhat.com/show_bug.cgi?id=1292322

Comment 3 James 2017-01-15 02:15:32 UTC
I tried another Intel iGPU system with F25/Mate and there's no issue. The failing system has Intel GM45 Express Chipset.

Comment 4 James 2017-01-16 03:27:11 UTC
This isn't a gtk issue. After more debugging, downgrading the following two  packages fixes the issue:

    Upgraded xorg-x11-server-Xorg-1.19.0-3.fc25.x86_64   @updates
    Upgrade                       1.19.1-1.fc25.x86_64   @updates
    Upgraded xorg-x11-server-common-1.19.0-3.fc25.x86_64 @updates
    Upgrade                         1.19.1-1.fc25.x86_64 @updates

Also it's not just firefox:

* VLC can trigger the crash by opening an audio network stream.
* The ABRT gui when clicking the configure button for workflows.

Comment 5 Olivier Fourdan 2017-01-27 15:51:43 UTC
Can you please provide the Xorg log after the crash (~/.local/share/xorg/*), it should contain a backtrace if Xorg crashed

Comment 6 James 2017-02-14 05:17:37 UTC
It looks like this has been fixed in 1.19.1-3.


Note You need to log in before you can comment on or make changes to this bug.