Bug 1413347 - [virtio-win][qemu-ga-win] could not install qemu-ga on some specific win2016 guest.
Summary: [virtio-win][qemu-ga-win] could not install qemu-ga on some specific win2016 ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Yvugenfi@redhat.com
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-15 08:03 UTC by xiagao
Modified: 2017-02-22 05:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-22 05:11:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
answer file (13.87 KB, application/xml)
2017-01-23 02:59 UTC, xiagao
no flags Details

Description xiagao 2017-01-15 08:03:25 UTC
Description of problem:

could not install qemu-ga on some specific win2016 guest, which are created in automation test.


Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.6.0-29.el7.x86_64
virtio-win-1.9.0-3.el7

How reproducible:
10/10

Steps to Reproduce:
1.boot up win2016 guest with virtio serial, and the guest image was created in our automation env.
/usr/libexec/qemu-kvm -name avocado-vt-vm1 -nodefaults -vga std -m 3G -smp 4 -usb -device usb-tablet,id=input0 -drive file=win2016-64-virtio.qcow2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=0 -vnc :0 -rtc base=localtime,clock=host,driftfix=slew -boot order=cd,menu=on -enable-kvm -monitor stdio -qmp tcp:0:1234,server,nowait -netdev tap,script=/etc/qemu-ifup,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:1a:4a:16:01:56 -drive file=/usr/share/virtio-win/virtio-win-1.9.0.iso,if=none,readonly=on,media=cdrom,format=raw,id=cdrom2 -device ide-drive,drive=cdrom2,bus=ide.1,unit=0,id=ide-cd2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -chardev socket,path=/tmp/qga.sock,server,nowait,id=qga -device virtserialport,bus=virtio-serial0.0,chardev=qga,name=org.qemu.guest_agent.0

2.install qemu-ga inside guest
3.

Actual results:
could't complete installation, pop up the error info:

There is a problem with this Windows Installer package.A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.

Expected results:
qemu-ga can be installed successfully.

Additional info:

Comment 4 Yvugenfi@redhat.com 2017-01-22 08:41:47 UTC
Could you please share the answer file that was used to create the guest? I am trying to download the image but it looks like it will take several days.

Thanks!

Comment 5 xiagao 2017-01-23 02:59:09 UTC
Created attachment 1243506 [details]
answer file

Comment 7 xiagao 2017-02-22 05:11:06 UTC
Can't reproduce on RTM Windows Server 2016.
close it.


Note You need to log in before you can comment on or make changes to this bug.