Bug 141341 - curl-devel should require libidn-devel
Summary: curl-devel should require libidn-devel
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: curl   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-30 16:12 UTC by Kir Kolyshkin
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-09 14:29:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kir Kolyshkin 2004-11-30 16:12:19 UTC
Description of problem:
I tried to build some program that uses libcurl; build failed with
error "libidl.so not found". The problem is libidl-devel package is
not installed, although needed if you want to build something with
libcurl, as curl-config --cflags output contains -lidl

Version-Release number of selected component (if applicable):
curl-devel-7.12.1-1

How reproducible:
always

Comment 1 Philip K. Warren 2004-12-03 19:39:25 UTC
I think you mean that it should require libidn-devel. curl-config
--libs returns '-lidn', which is only available in the libidn-devel
package.

Comment 2 Kir Kolyshkin 2004-12-04 09:50:15 UTC
sure it's libidn-devel; sorry for the mistype.


Note You need to log in before you can comment on or make changes to this bug.