Bug 1413550 - better error message is needed when disabling a missing policy module
Summary: better error message is needed when disabling a missing policy module
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Vit Mojzis
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 11:33 UTC by Milos Malik
Modified: 2019-02-27 12:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-27 12:33:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Milos Malik 2017-01-16 11:33:49 UTC
Description of problem:
* exit code is correct, but explanatory error message disappeared

Version-Release number of selected component (if applicable):
libsemanage-2.5-4.el7.x86_64
libsemanage-python-2.5-4.el7.x86_64
policycoreutils-2.5-8.el7.x86_64
policycoreutils-python-2.5-8.el7.x86_64

How reproducible:
* always

RHEL-7.2
========
# semanage module -d non-existent
libsemanage.get_module_file_by_name: Module non-existent was not found. (No such file or directory).
ValueError: Could not disable module non-existent (remove failed)
# echo $?
1
#

RHEL-7.3
========
# semanage module -d non-existent
OSError: No such file or directory
# echo $?
1
#

Expected results:
* error message is explanatory again (the same as in RHEL-7.2)

Comment 1 Milos Malik 2017-01-16 14:54:17 UTC
The problem also appears when enabling a missing policy module:

# semanage module --enable xyz
OSError: No such file or directory
# semanage module --disable xyz
OSError: No such file or directory
#

Comment 4 Zdenek Pytela 2019-02-27 12:33:38 UTC
This issue was not selected to be included in Red Hat Enterprise Linux 7.7 because it is seen either as low or moderate impact to a small number of use-cases. The next release will be in Maintenance Support 1 Phase, which means that qualified Critical and Important Security errata advisories (RHSAs) and Urgent Priority Bug Fix errata advisories (RHBAs) may be released as they become available.

We will now close this issue, but if you believe that it qualifies for the Maintenance Support 1 Phase, please re-open; otherwise, we recommend moving the request to Red Hat Enterprise Linux 8 if applicable.


Note You need to log in before you can comment on or make changes to this bug.