Bug 141365 - Samba client fails to write to Samba Server
Samba client fails to write to Samba Server
Status: CLOSED DUPLICATE of bug 140427
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 13:11 EST by Ed Holden
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 17:54:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Holden 2004-11-30 13:11:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Since installing Fedora Core 3 I have been unable to successfully
write to my Samba server, though it worked fine in Fedora Cores 1 and
2.  The exact problem is elusive.  First I back up a file, say a
simple text file.  When making the backup, the cp command hangs for
perhaps twenty seconds, even when the file is only a few KB.  Thouch
cp does eventually work.

When I try to edit the file with kate or gedit (tried both), it is
zeroed out on the server and the editor hangs, effectively deleting
the data in the file.  I generally have to kill the editor, or quit
without saving.

I also tried vi, which was the most interesting editor of the bunch. 
It takes a couple minutes to display the text of the file, which is
only about 20 lines.  When I try to write the file, it simply hangs
for about five minutes, during which time the mounted share becomes
unuseable even in other terminals and in Konqueror.  I can't even list
the contents.  And I noticed that a delete operation I had on a 7 MB
file was cancelled due to the writing in vi.

Ummounting the shares and the nremounting them works great, until the
next time I try to write a file.

Version-Release number of selected component (if applicable):
3.0.8-0.pre1.3

How reproducible:
Always

Steps to Reproduce:
1. Mount "home" share on server to local /media/home directory.
2. Make a backup of a file.
3. Edit the file.  Try to save it.
    

Actual Results:  The file cannot be edited.  Editing is slow and save
operations seem to fail.  Usually the file is rendered empty.

Expected Results:  The file should quickly save.

Additional info:

This Samba server runs Fedora Core 1 and is in use by many Windows
clients, plus my machine.  It seems to have all of the appropriate
permissions on the files and directories in question.  Its
configuration is unchanged since I used it successfully

I am not sure whether it is appropriate to set this bug's severity to
High, but it involves loss of data so it seemed to fit.
Comment 1 Sitsofe Wheeler 2004-12-03 05:16:55 EST
After attempting a write are there any selinux related messages in the output of
dmseg?
Comment 2 Ed Holden 2004-12-03 13:08:18 EST
None that I can see, but here is the end of the current dmesg output, from the
moment the SMB share is mounted:

 smbfs: Unrecognized mount option noexec
 SELinux: initialized (dev smbfs, type smbfs), uses genfs_contexts
 smbfs: Unrecognized mount option noexec
 SELinux: initialized (dev smbfs, type smbfs), uses genfs_contexts
 smb_trans2: invalid data, disp=0, cnt=0, tot=0, ofs=0
 smb_add_request: request [0c2f5040, mid=457] timed out!
 smb_trans2: invalid data, disp=0, cnt=0, tot=0, ofs=0
 smb_trans2: invalid data, disp=0, cnt=0, tot=0, ofs=0
 smb_add_request: request [0c2f5040, mid=978] timed out!
 smb_trans2: invalid data, disp=0, cnt=0, tot=0, ofs=0
 smb_add_request: request [0c2f5ee0, mid=1327] timed out!
 smb_add_request: request [0c2f5040, mid=1530] timed out!

This was after I created a text file in Konqueror and then opened it, and then
tried to save it.  The save failed as usual.  But anticipating this response to
your question, I also took the liberty of setting SELinux to permissive mode and
then rebooted.  The results are the same, so it may be a Samba issue.
Comment 3 Sitsofe Wheeler 2004-12-03 14:35:32 EST
This sounds a bit like bug 13857 possibly bug 140427 then...
Comment 4 Ed Holden 2004-12-03 17:54:09 EST
Interesting - thanks for pointing that out.  I just booted to the original FC3
kernel 2.6.9-1.667 and the problem is gone.  So this is a kernel issue with SMB
support, and it is indeed probably a duplicate of 140427.  I'll mark it as such
- and thanks for the temporary workaround!

*** This bug has been marked as a duplicate of 140427 ***

Note You need to log in before you can comment on or make changes to this bug.