Bug 141367 - USB 6-in-1 flash reader not on whitelist, only 1 device usable
USB 6-in-1 flash reader not on whitelist, only 1 device usable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 13:22 EST by Jurgen Kramer
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.9-1.724_FC3smp
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 13:19:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2004-11-30 13:22:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
My 6-in-1 USB card reader is not on the whitelist, so currently
only one device is working (missing SCSI_MULTI_LUN in default FC3
kernel). Could my device be added to the whitelist?






Version-Release number of selected component (if applicable):
 2.6.9-1.681_FC3smp (probably applies to all FC/RH kernels)

How reproducible:
Always

Steps to Reproduce:
1. Boot system ;)
2.
3.
    

Actual Results:  Only one out of 6 devices usable.

Expected Results:  All 6 devices from the 6-in-1 reader usable (sdb
through sdg)

Additional info:
Comment 1 Jurgen Kramer 2004-11-30 13:23:37 EST
Relevant ouput from lsusb -v:

Bus 003 Device 002: ID 0c0b:27cb Dura Micro, Inc. (Acomdata) 6-in-1
Flash Reader  and Writer
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x0c0b Dura Micro, Inc. (Acomdata)
  idProduct          0x27cb 6-in-1 Flash Reader and Writer
  bcdDevice            1.00
  iManufacturer           1
  iProduct                2 MultiFlash
  iSerial                 3 1E290C010101
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           39
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0x80
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk (Zip)
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval             255
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0040  bytes 64 once
        bInterval             255
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               none
          Usage Type               Data
        wMaxPacketSize     0x0002  bytes 2 once
        bInterval               1
  Language IDs: (length=4)
     0409 English(US)

Relevant output from /proc/scsi/scsiHost: 
scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: DMI      Model: MultiFlash       Rev: 3.00
  Type:   Direct-Access                    ANSI SCSI revision: 02

Thanks,

Jurgen
Comment 2 Dave Jones 2004-12-06 23:30:49 EST
fixed in the -698 kernel thats in updates-testing.
Comment 3 Jurgen Kramer 2004-12-08 15:04:50 EST
(In reply to comment #2)
> fixed in the -698 kernel thats in updates-testing.
> 

I've just tested -698, unfortunately the bug is not resolved. I still only get
one out of 6 devices :(

Output from cat /proc/scsi/scsi with -689smp:

[root@paragon ~]# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: 3ware    Model: Logical Disk 00  Rev: 1.00
  Type:   Direct-Access                    ANSI SCSI revision: ffffffff
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: Maxtor 6B300S0   Rev: BANC
  Type:   Direct-Access                    ANSI SCSI revision: 05
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor: DMI      Model: MultiFlash       Rev: 3.00
  Type:   Direct-Access                    ANSI SCSI revision: 02

Jurgen
Comment 4 Jurgen Kramer 2004-12-08 15:10:39 EST
Bug not fixed in kernel -698smp from updates-testing.
Comment 5 Jurgen Kramer 2004-12-13 15:36:36 EST
When I modify scsi_devinfo.c a get all devices:

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: 3ware    Model: Logical Disk 00  Rev: 1.00
  Type:   Direct-Access                    ANSI SCSI revision: ffffffff
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: Maxtor 6B300S0   Rev: BANC
  Type:   Direct-Access                    ANSI SCSI revision: 05
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor: DMI      Model: MultiFlash       Rev: 3.00
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi3 Channel: 00 Id: 00 Lun: 01
  Vendor: DMI      Model: MultiFlash       Rev: 3.00
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi3 Channel: 00 Id: 00 Lun: 02
  Vendor: DMI      Model: MultiFlash       Rev: 3.00
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi3 Channel: 00 Id: 00 Lun: 03
  Vendor: DMI      Model: MultiFlash       Rev: 3.00
  Type:   Direct-Access                    ANSI SCSI revision: 02

Patch (diff -u) against 698 sources from updates-testing:

--- scsi_devinfo.c      2004-12-13 21:30:51.954277957 +0100
+++ /tmp/scsi_devinfo.c 2004-12-13 21:25:37.000000000 +0100
@@ -213,6 +213,7 @@
        {"USB2.0", "SMARTMEDIA/XD", NULL, BLIST_FORCELUN},
        {"Y-E DATA", "CF Card Reader", "1.03", BLIST_FORCELUN},
        {"Zynet", "USB Storage-SMC", "I03A", BLIST_FORCELUN},
+       {"DMI", "MultiFlash", "3.00", BLIST_FORCELUN},

        { NULL, NULL, NULL, 0 },
 };

This is currently not in 698.
Comment 6 Dave Jones 2004-12-13 15:40:40 EST
Try the latest from
http://people.redhat.com/davej/kernels/Fedora/FC3/
Comment 7 Jurgen Kramer 2004-12-16 12:15:18 EST
OK, the problem is fixed in testing kernel 715.
Thanks.
Comment 8 Jurgen Kramer 2005-01-05 13:19:14 EST
Solved in release kernel 724. Bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.