Bug 1413743 - Black screen on boot after the GRUB2 menu
Summary: Black screen on boot after the GRUB2 menu
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: i686
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-16 20:57 UTC by Juhani Jaakola
Modified: 2019-01-09 12:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-21 14:51:27 UTC
Type: Bug


Attachments (Terms of Use)
/var/log/messages with no kernel parameters - this results in black screen (139.89 KB, text/plain)
2017-01-16 20:57 UTC, Juhani Jaakola
no flags Details
/var/log/messages with kernel parameter "single" - this boots normally (143.17 KB, text/plain)
2017-01-16 20:59 UTC, Juhani Jaakola
no flags Details

Description Juhani Jaakola 2017-01-16 20:57:58 UTC
Created attachment 1241405 [details]
/var/log/messages with no kernel parameters - this results in black screen

Description of problem:
I updated to kernel-4.9.3-200.fc25.i686 and rebooted. The system boots, but after the GRUB2 menu the screen is completely black. However, if I add parameter "single" to kernel parameters on GRUB2 menu, the system boots and the screen works fine. With Ctrl-D I can continue normal booting.

Version-Release number of selected component (if applicable):
kernel-4.9.3-200.fc25.i686

How reproducible:
Always

Steps to Reproduce:
1. Update to kernel-4.9.3-200.fc25.i686
2. Try booting
3.

Actual results:
Black screen

Expected results:
Normal boot

Additional info:
My motherboard is M5A78L-M LX, BIOS 0801   11/30/2011.

I use processor AMD FX(tm)-4100 Quad-Core Processor (family: 0x15, model: 0x1, stepping: 0x2).

When the system boots, file /var/log/messages is appended with boot messages, I have included file contents with and without the parameter "single". When I get the black screen, the VRAM size is too big, compare the following two lines:

radeon 0000:01:05.0: VRAM: 256M 0x00000000C0000000 - 0x00000000CFFFFFFF (256M used)
radeon 0000:01:05.0: VRAM: 3584M 0x000000FFFF000000 - 0x00000100DEFFFFFF (3584M used)

And when I get the black screen, I get lots of ACPI errors, like the following:

ACPI Error: Unknown opcode 0x16 at table offset 0x228C, ignoring (20160831/psobject-108)
ACPI Error: Result stack is empty! State=f35cd400 (20160831/dswstate-99)
ACPI Exception: AE_AML_NO_RETURN_VALUE, Missing or null operand (20160831/dsutils-656)
[Firmware Info]: PCI: MMCONFIG at [mem 0xe0000000-0xefffffff] not reserved in ACPI motherboard resources

On this same PC I have had problems with kernels 4.8.*. I could work around them by adding kernel parameters "radeon.dpm=0" or "iommu=off", but this time these additions did not help. But when I added only the parameter "single" I could get screen output.

Comment 1 Juhani Jaakola 2017-01-16 20:59:51 UTC
Created attachment 1241406 [details]
/var/log/messages with kernel parameter "single" - this boots normally

Comment 2 Juhani Jaakola 2017-02-06 18:24:45 UTC
I had to boot the machine, and now it does not boot even with the "single" parameter! I did not make any updates.

After that I upgraded to the latest BIOS (version 1603) but it didn't change anything.

I can boot the system from the Fecora 25 LXDE Live CD (or actually a USB memory stick).

Comment 3 Juhani Jaakola 2017-02-09 08:56:01 UTC
As I wrote in the original Description of the bug, I can see a wrong size for the VRAM in /var/log/messages. Because of that I decided to try booting with kernel parameter radeon.vramlimit=256 but it did not change anything: immediately after choosing a kernel from the GRUB2 boot menu, the system reboots.

I installed kernel-4.8.6-300.fc25.i686 and kernel-4.9.3-200.fc25.i686 by using a live CD and chroot, but those kernels did not change anything. That is strange, because I can boot from LXDE Live CD which has kernel-4.8.6-300.fc25.i686 but when I install the same kernel to hard disk (via live CD and chroot), I can't boot it!

Comment 4 Juhani Jaakola 2017-02-18 14:59:35 UTC
I installed kernel-4.9.9-200.fc25.i686 by using a live CD and chroot, but it didn't help.

Because I noticed the following differences in detected VRAM, I tried to disable the radeon module, but it didn't help. When the system boots normally, the messages file contains:

kernel: radeon 0000:01:05.0: VRAM: 256M 0x00000000C0000000 - 0x00000000CFFFFFFF (256M used)
kernel: [drm] Detected VRAM RAM=256M, BAR=256M
kernel: [drm] RAM width 32bits DDR

but when the system boots with a black screen it contains:

kernel: radeon 0000:01:05.0: VRAM: 3584M 0x000000FFFF000000 - 0x00000100DEFFFFFF (3584M used)
kernel: [drm] Detected VRAM RAM=3584M, BAR=256M
kernel: [drm] RAM width 128bits DDR

I tried to disable radeon module by adding these three parameter sets to the kernel command line in GRUB2:

radeon.modeset=0 rd.driver.blacklist=radeon nomodeset
radeon.modeset=0 rd.blacklist=radeon nomodeset
rd.radeon=disable

When I add any of these parameter sets to the kernel command line, the system just reboots within a second or two!

Comment 5 Juhani Jaakola 2017-02-21 14:51:27 UTC
I booted my system via a Fedora 25 LXDE Live CD using boot parameter "root=LABEL=/ ro single" and then updated my system to the latest packages, including kernel-4.9.10-200.fc25.i686. Now my system boots without any extra boot parameters, and VRAM is detected as 256M again!


Note You need to log in before you can comment on or make changes to this bug.