Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413853 - Cannot do JenkinsPipeline build on dev-preview-stg
Summary: Cannot do JenkinsPipeline build on dev-preview-stg
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Abhishek Gupta
QA Contact: yasun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 07:20 UTC by Wenjing Zheng
Modified: 2017-04-05 20:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-05 20:54:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wenjing Zheng 2017-01-17 07:20:20 UTC
Description of problem:
Below error appears when try to create JenkinsPipeline build strategy:
error: buildconfigs "sample-pipeline" is forbidden: build strategy JenkinsPipeline is not allowed

Version-Release number of selected component (if applicable):
Online dev-preview-stg
OpenShift Master:v3.4.0.39 (online version 3.4.0.13)
Kubernetes Master:v1.4.0+776c994

How reproducible:
always

Steps to Reproduce:
1.Create a project
oc new-project pipelineproject
2.Create pipeline bc and other resources
$ oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/jenkins/pipeline/samplepipeline.json

Actual results:
Below error appears:
error: buildconfigs "sample-pipeline" is forbidden: build strategy JenkinsPipeline is not allowed

Expected results:
Should allow JenkinsPipeline build strategy

Additional info:
Pipeline buildconfigs can be created on dev-preview-int which has the same server version with dev-preview-stg

Comment 1 Cesar Wong 2017-01-17 15:03:21 UTC
Looks like a misconfiguration of the build strategy admission control.

Comment 3 Stefanie Forrester 2017-01-18 18:02:06 UTC
I looked at the openshift-ansible upgrade script and found we were missing this:

oadm policy reconcile-cluster-role-bindings system:build-strategy-jenkinspipeline --confirm

Once I ran that, and tested pipelines again, the build worked.

Comment 4 yasun 2017-01-19 01:55:04 UTC
Jenkins pipeline can be created and built from jenkins web console.


Note You need to log in before you can comment on or make changes to this bug.