Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1413903 - Can't change smartcard mode from host to passthrough in virt-manager
Summary: Can't change smartcard mode from host to passthrough in virt-manager
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.9
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-17 09:54 UTC by mxie@redhat.com
Modified: 2017-03-02 19:30 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-02 19:30:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (76.87 KB, image/png)
2017-01-17 09:54 UTC, mxie@redhat.com
no flags Details
virt-manager-debug.log (7.84 KB, text/plain)
2017-01-17 09:56 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2017-01-17 09:54:39 UTC
Created attachment 1241655 [details]
screenshot

Description of problem:
Can't change smartcard mode from host to passthrough in virt-manager

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-34.el6.x86_64
libvirt-0.10.2-62.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.501.el6.x86_64
python-virtinst-0.600.0-31.el6.noarch


How reproducible:
100%

Steps to Reproduce:
1 Prepare a guest in virt-manager and add smartcard which is host to guest
Open guest's virtual hardware detail-> add hardware -> select smartcard device and mode is host ->Finish

2.Return to  guest's virtual hardware detail, try to change smartcard mode from host to passthrough ,then will pop up error"Error changing VM configuration: XML error: passthrough mode requires a character device type attribute", details pls refer to screenshot and log

Actual results:
As above description

Expected results:
Can change smartcard mode from host to passthrough in virt-manager


Additional info:
1.Can't reproduce this problem on rhel7.3

Comment 1 mxie@redhat.com 2017-01-17 09:56:10 UTC
Created attachment 1241656 [details]
virt-manager-debug.log

Comment 2 Cole Robinson 2017-03-02 19:30:55 UTC
Thanks for the report, but I don't think this is worth fixing for RHEL6, given that:

1) there's no customer/user complaint
2) I don't think there's many people using this functionality with virt-manager, 3) you can workaround it by removing the device and using 'add hardware' to add a passthrough one
4) rhel6 is old and the virt-manager code there is old too so it will need a custom patch

FYI this works upstream, but the code is vastly different

Closing as WONTFIX but please reopen if anyone disagrees


Note You need to log in before you can comment on or make changes to this bug.