Bug 141399 - Evolution is missing a run-time dependency on openldap
Summary: Evolution is missing a run-time dependency on openldap
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
: 140127 (view as bug list)
Depends On:
Blocks: 135876
TreeView+ depends on / blocked
 
Reported: 2004-11-30 21:57 UTC by Dave Malcolm
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 17:51:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Malcolm 2004-11-30 21:57:59 UTC
In evolution-2.0.2: addressbook/gui/component/Makefile.am uses LDAP_CFLAGS and
LDAP_LIBS

(this is to allow automated detection of the correct configuration of the
addressbook LDAP backend, which is then used by evolution-data-server)

from config.log:
LDAP_CFLAGS=''
LDAP_LIBS=' -lldap -llber -lresolv -lnsl'

We link dynamically with OpenLDAP; we already have a BuildRequires, but not a
Requires.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dave Malcolm 2004-11-30 22:23:58 UTC
ldd /usr/lib/evolution/2.0/components/libevolution-addressbook.so | grep ldap
        libldap-2.2.so.7 => /usr/lib/libldap-2.2.so.7 (0x00b71000)
rpm -qf /usr/lib/libldap-2.2.so.7
openldap-2.2.13-2

ldd /usr/lib/evolution/2.0/components/libevolution-addressbook.so | grep lber
        liblber-2.2.so.7 => /usr/lib/liblber-2.2.so.7 (0x00722000)
rpm -qf /usr/lib/liblber-2.2.so.7
openldap-2.2.13-2

ldd /usr/lib/evolution/2.0/components/libevolution-addressbook.so | grep resolv
        libresolv.so.2 => /lib/libresolv.so.2 (0x0072a000)
ldd /usr/lib/evolution/2.0/components/libevolution-addressbook.so | grep nsl
        libnsl.so.1 => /lib/libnsl.so.1 (0x00c4b000)
These are provided by glibc

So we have a runtime requirement on openldap; otherwise the addressbook
component can't be loaded.

Comment 2 Dave Malcolm 2004-11-30 22:32:30 UTC
(I saw this when someone managed to "rpm -e cyrus-sasl" and then the addressbook
component stopped appearing in Evolution; cyrus-sasl is a requirement for
openldap, hence fixing this should stop that recurring)

Comment 3 Dave Malcolm 2004-11-30 22:37:19 UTC
Adding to RHEL4 RC blocker, since without this being fixed it's possible to
install evolution in such a way that the addressbook can't be used.

Comment 4 Dave Malcolm 2004-11-30 22:53:04 UTC
Hmmm... now I'm not sure how the situation arising in comment #2 arose (this was
on mclasen's machine)

The evolution package already depends on the specific .so files:
libldap-2.2.so.7 and liblber-2.2.so.7, so there's already an implicit direct
dependency on the openldap package, which should have thus created an indirect
implicit dependency on cyrus-sasl.

(adding mclasen to cc)

Comment 5 Dave Malcolm 2004-12-01 02:17:43 UTC
*** Bug 140127 has been marked as a duplicate of this bug. ***

Comment 6 Dave Malcolm 2004-12-01 02:20:12 UTC
(I also added bug #140127 in response to the incident in comment #2,
and promptly forgot about it; that bug has the specific error message)

Comment 7 Dave Malcolm 2004-12-01 17:51:56 UTC
OK - according to Matthias this was only seen once, and on a machine
running Rawhide; we believe it was a bug in RPM/yum since yum was
particularly unstable at the time (python 2.3->2.4 migrations etc); it
appears that he was able to erroneously install evolution without
cyrus-sasl.

It looks like the dependencies are correct, so I'm going to mark this
as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.