Bug 141417 - wrong buildrequires on xorg-x11-devel/XFree86-devel
wrong buildrequires on xorg-x11-devel/XFree86-devel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 18:58 EST by Luciano Rocha
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 12:24:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luciano Rocha 2004-11-30 18:58:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.2)
Gecko/20040816

Description of problem:
pango-1.6.0-7.src.rpm (also on fc3?) has
a BuildRequires: xorg-x11-devel >= 4.2.99.

OTOH, the -devel subpackage has a Requires: XFree86-devel >= 4.2.99.

The requirement makes more sence for XFree86-devel, because there
never was a xorg-x11-devel 4.2.99.

Also, older versions of xorg-x11, that used a different numbering
system, like xorg-x11-0.0.6.6-0.0.2004_03_11.9, provides the
XFree86-devel >= 4.2.99 but, I assume, not the xorg-x11-devel >= 4.2.99.

pango-1.6.0 seems to be working fine with that version of xorg-x11
(tested a little in a PPC with YDL 4.0, with gnome, thunderbird &
firefox), so I see no reason to require a newer version of xorg-x11.
(I can't speak for the standards XFree86 >= 4.2.99, though.)


Version-Release number of selected component (if applicable):
pango-1.6.0-7

How reproducible:
Always

Steps to Reproduce:
1. rpm -i pango-1.6.0-7.src.rpm
2. check the spec

Additional info:
Comment 1 Matthias Clasen 2005-11-01 12:24:56 EST
Will be fixed soon, when we fix the requires for modular x

Note You need to log in before you can comment on or make changes to this bug.