Bug 141421 - foomatic-gswrapper loads incorrect omni libraries on x86_64
foomatic-gswrapper loads incorrect omni libraries on x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Omni (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 140300 (view as bug list)
Depends On:
Blocks: 141499
  Show dependency treegraph
 
Reported: 2004-11-30 19:05 EST by David Betz
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 11:06:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CUPS log showing error in gs as called from foomatic-gswrapper (3.80 KB, text/plain)
2004-11-30 19:09 EST, David Betz
no flags Details

  None (edit)
Description David Betz 2004-11-30 19:05:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
I was trying to use the CUPS printing system to print some documents
and received the errors listed at the end of this message. 
Apparently, gs was trying to link against /usr/lib/Omni instead of
/usr/lib64/Omni.  When I added 

$ENV{'LD_LIBRARY_PATH'} ='/usr/lib64/Omni';

to the foomatic-gswrapper perl script, I was subsequently able to print.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-3

How reproducible:
Didn't try


Additional info:
Comment 1 David Betz 2004-11-30 19:09:26 EST
Created attachment 107676 [details]
CUPS log showing error in gs as called from foomatic-gswrapper
Comment 2 Tim Waugh 2004-12-01 12:39:26 EST
Please try the update mentioned here:

http://www.redhat.com/archives/fedora-test-list/2004-December/msg00004.html

Make sure to undo the modificationn you made to /usr/bin/fooamtic-gswrapper when
testing it.  Thanks.
Comment 3 Tim Waugh 2004-12-03 05:06:56 EST
*** Bug 140300 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.