Bug 1414241 - If namespace begin with non letter, logging deployement will be always failed due to keytool error
Summary: If namespace begin with non letter, logging deployement will be always failed...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: Xia Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 06:55 UTC by Junqi Zhao
Modified: 2017-01-18 14:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 14:44:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
logging deployer pod log (26.72 KB, text/plain)
2017-01-18 06:55 UTC, Junqi Zhao
no flags Details

Description Junqi Zhao 2017-01-18 06:55:37 UTC
Created attachment 1242041 [details]
logging deployer pod log

Description of problem:
If namespace begin with non letter, logging deployement will be always failed due to keytool error.


Version-Release number of selected component (if applicable):
openshift3/logging-kibana    b5f8fe3fa247
openshift3/logging-auth-proxy    139f7943475e
openshift3/logging-fluentd    e0b004b486b4
openshift3/logging-elasticsearch    7015704dc0f8
openshift3/logging-curator    7f034fdf7702
openshift3/logging-deployer    910537ac6658

How reproducible:
Always

Steps to Reproduce:
1. Create a new project, and the project name start with non letter, such as 99bill
2. Deploy logging stacks

Actual results:

Deployment failed, error throws out, indicate that the DNSName components must begin with a letter.

Error trace:
Generating keystore and certificate for node logging-es
keytool error: java.lang.RuntimeException: java.io.IOException: DNSName components must begin with a letter

More info see the attached deployer_pod_log.txt

Expected results:

Deployment should be successed, but this error is caused by keytool, it is better to add note in logging documentation, advise the project name should begin with a letter.

Comment 1 Jeff Cantrill 2017-01-18 14:44:24 UTC
This is a limitation that would need to be addressed in java keytool.  User's will have to limit their logging projects to begin with alpha chatacters.


Note You need to log in before you can comment on or make changes to this bug.