Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1414261 - [DOCS] Lost glusterfs endpoints after restart active master controllers host
Summary: [DOCS] Lost glusterfs endpoints after restart active master controllers host
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.3.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Traci Morrison
QA Contact: Weihua Meng
Vikram Goyal
URL:
Whiteboard: 3.10-release-plan
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 08:07 UTC by Kenjiro Nakayama
Modified: 2020-02-14 18:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-05 15:05:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1408293 0 medium CLOSED [DOCS] Gluster on OpenShift Examples Use Wrong Names 2021-02-22 00:41:40 UTC

Internal Links: 1408293

Description Kenjiro Nakayama 2017-01-18 08:07:54 UTC
Description of problem:
===
- We lost glusterfs endpoins after restart active master controllers host + 10-15miutes even though we created service for the endpoints.

Version-Release number of selected component (if applicable):
===
- OCP 3.3

How reproducible:
===
- Restart "active" master controllers and wait for 10-15minutes

Steps to Reproduce:
===
  1. Create endpoint[1] and service[2].
  2. Shut down host which is running active master-controllers
  3. Wait for 10 or 15minutes. 

*IMPORTANT*
 * Need to reboot "active" master controllers hosts in step-2.
 * Need to wait for 10-15minutes to see the endpoints disappearance in step-3.

Actual results:
===
- In step-3, GlusterFS endpoints gone.

Expected results:
===
- In step-3, GlusterFS endoints persist.

[1]---
# cat gluster-service.yaml 
apiVersion: v1
kind: Service
metadata:
  name: gluster-service 
spec:
  ports:
  - port: 1

[2]---
# cat gluster-endpoints.yaml 
apiVersion: v1
kind: Endpoints
metadata:
  name: gluster-endpoints 
subsets:
- addresses:              
  - ip: 192.168.122.21
  ports:                  
  - port: 1
    protocol: TCP
- addresses:
  - ip: 192.168.122.22
  ports:
  - port: 1
    protocol: TCP

Comment 1 Kenjiro Nakayama 2017-01-19 02:15:19 UTC
Since this issue is critical for the enterprise system and we don't see any workaround, please backport to OCP 3.3 when you fixed the issue.

Comment 2 Humble Chirammal 2017-01-20 07:06:49 UTC
Kenjiro, In above example, the service and endpoint are having different names. Is there a typo? if not, the headless service has to be connected with endpoint with the same name.

Comment 3 Kenjiro Nakayama 2017-01-20 07:23:36 UTC
Hi, thank you for your update. What does "same name" means? Does it mean metadata.name? The configuration is exactly same with example in the official docs - https://docs.openshift.com/container-platform/3.3/install_config/storage_examples/gluster_example.html#complete-example-using-gusterfs-creating-the-gluster-endpoints

Comment 4 Prasanth 2017-01-20 09:18:05 UTC
(In reply to Kenjiro Nakayama from comment #3)
> Hi, thank you for your update. What does "same name" means? Does it mean
> metadata.name? 

Yes, that's right. The "metadata:   name:" defined in your Gluster service definition must be defined in the endpoints definition as well to match the endpoints to this service. So in short, the "metadata:   name:" should be the same in both Gluster service definition and Gluster endpoint definition.


The configuration is exactly same with example in the
> official docs -
> https://docs.openshift.com/container-platform/3.3/install_config/
> storage_examples/gluster_example.html#complete-example-using-gusterfs-
> creating-the-gluster-endpoints

The official doc is actually here: https://access.redhat.com/documentation/en/openshift-container-platform/3.3/paged/installation-and-configuration/chapter-19-configuring-persistent-storage#install-config-persistent-storage-persistent-storage-glusterfs

Please try using the examples mentioned in the above official doc and let us know if you still face any issues.

Comment 5 Kenjiro Nakayama 2017-01-20 10:06:25 UTC
Hi Humble and Prasanth,

Thank you. I confirmed that same name could work fine. But actually, both docs are RH "official" docs, so we have to update the example one. Could you assign this ticket to the docs team? Or should I open new ticket?

* wrong
https://docs.openshift.com/container-platform/3.3/install_config/storage_examples/gluster_example.html

* correct
https://docs.openshift.com/container-platform/3.3/install_config/persistent_storage/persistent_storage_glusterfs.html

Comment 7 Traci Morrison 2018-04-04 21:49:33 UTC
Sent email to @jparra asking for additional information.


Note You need to log in before you can comment on or make changes to this bug.