Bug 141430 - /usr/share/printconf/util/printconf_conf.py returns auto variable before it is assigned
Summary: /usr/share/printconf/util/printconf_conf.py returns auto variable before it i...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 150377 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-01 01:52 UTC by David Betz
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 0.6.119-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-10 16:00:35 UTC


Attachments (Terms of Use)

Description David Betz 2004-12-01 01:52:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
I am using a pl2303 usb-to-parallel cable to drive my old laserjet 4
from my new computer.  When setting up the printer,
system-config-printer hangs with an error message about "auto is
returned before it is assigned", in line 1392 of file
/usr/share/printconf/util/printconf_conf.py.  I changed the line from

return { "auto" : auto }

to

return { "auto" : "" }

I was subsequently able to set up the printer.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116-1

How reproducible:
Always

Steps to Reproduce:
1.  use a pl2303 cable to attach a parallel-port based printer to the
test computer
2.  use system-config-printer to try and install the printer
   

Actual Results:  system-config-printer hangs

Expected Results:  I should be able to install the printer.

Additional info:

Comment 1 Tim Waugh 2004-12-01 13:36:39 UTC
Thanks.  Fixed in CVS (I think the correct line is "return { }").

Comment 3 Tim Waugh 2005-03-07 17:26:39 UTC
*** Bug 150377 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.