This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 141457 - Kmail can crash when deleting an email
Kmail can crash when deleting an email
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 04:25 EST by Nigel Horne
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 10:32:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Stack trace from within gdb (3.03 KB, text/plain)
2004-12-01 04:26 EST, Nigel Horne
no flags Details
Stack trace from KDE crash handler (2.40 KB, text/plain)
2004-12-01 04:26 EST, Nigel Horne
no flags Details

  None (edit)
Description Nigel Horne 2004-12-01 04:25:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.3)
Gecko/20041020

Description of problem:
From time to time deleting an email causes kmail to crash with a
SIGSEGV. I can find no pattern.

Version-Release number of selected component (if applicable):
kdepim-3.3.1-1

How reproducible:
Sometimes

Steps to Reproduce:
1. Start kmail
2. Delete a message
3.
    

Actual Results:  Kmail dies

Expected Results:  The message should be deleted

Additional info:

I have tried to get debug information but it's not easy.
I have installed:
kdepim-debuginfo-3.3.1-3
qt-debuginfo-3.3.3-12
kdelibs-debuginfo-3.3.1-4

and run under gdb but both gdb and the kde crash handler give lots of
no debugging info messages.

I have attached two debug traces, one from gdb and one from the crash
handler in the hope that it will help.
Comment 1 Nigel Horne 2004-12-01 04:26:07 EST
Created attachment 107699 [details]
Stack trace from within gdb
Comment 2 Nigel Horne 2004-12-01 04:26:40 EST
Created attachment 107700 [details]
Stack trace from KDE crash handler
Comment 3 Ngo Than 2004-12-04 06:28:16 EST
it seems to be fixed in new upstream.
http://bugs.kde.org/show_bug.cgi?id=90320
Comment 4 Nigel Horne 2004-12-04 07:05:08 EST
When will this be available on FC3? Closing a bug doesn't make it go away!
Comment 5 Ngo Than 2004-12-04 07:11:10 EST
i'm preparing KDE-3.3.2 for FC3. It will be available on ftp.kde.org
next week.
Comment 6 Nigel Horne 2004-12-04 07:52:50 EST
When will it be available by up2date?
Comment 7 Nigel Horne 2005-01-20 12:22:22 EST
This bug still occurs, and FC3 is still on kdepim-3.3.1-1.

When will a fix be released?

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208101184 (LWP 21814)]
[KCrash handler]
#4  0x00353429 in KMHeaders::msgHeaderChanged ()
   from /usr/lib/libkmailprivate.so.0
#5  0x00362e53 in KMHeaders::qt_invoke () from
/usr/lib/libkmailprivate.so.0
#6  0x05e60d29 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#7  0x0038c286 in KMFolder::msgHeaderChanged ()
   from /usr/lib/libkmailprivate.so.0
#8  0x0038c626 in KMFolder::qt_emit () from /usr/lib/libkmailprivate.so.0
#9  0x05e60e1d in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#10 0x003a71e6 in FolderStorage::msgHeaderChanged ()
   from /usr/lib/libkmailprivate.so.0
#11 0x003a724b in FolderStorage::headerOfMsgChanged ()
   from /usr/lib/libkmailprivate.so.0
#12 0x003fa679 in KMMsgBase::setStatus () from
/usr/lib/libkmailprivate.so.0
#13 0x002c8dde in KMMessage::setStatus () from
/usr/lib/libkmailprivate.so.0
#14 0x002c9535 in KMMessage::updateAttachmentState ()
   from /usr/lib/libkmailprivate.so.0
#15 0x002c9966 in KMMessage::fromDwString ()
   from /usr/lib/libkmailprivate.so.0
#16 0x002c9a4f in KMMessage::fromByteArray ()
   from /usr/lib/libkmailprivate.so.0
#17 0x004e7489 in KMail::ImapJob::slotGetMessageResult ()
   from /usr/lib/libkmailprivate.so.0
#18 0x004ea5e1 in KMail::ImapJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so.0
#19 0x05e60da0 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x0107b20d in KIO::Job::result () from /usr/lib/libkio.so.4
#21 0x0107b280 in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#22 0x0107d884 in KIO::SimpleJob::slotFinished () from
/usr/lib/libkio.so.4
#23 0x0108c375 in KIO::TransferJob::slotFinished () from
/usr/lib/libkio.so.4
#24 0x0107c96e in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#25 0x05e60da0 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x05e6147a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x01069f3c in KIO::SlaveInterface::finished () from
/usr/lib/libkio.so.4
#28 0x0106cb36 in KIO::SlaveInterface::dispatch () from
/usr/lib/libkio.so.4
#29 0x0106b72f in KIO::SlaveInterface::dispatch () from
/usr/lib/libkio.so.4
#30 0x01067706 in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#31 0x01067a8f in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#32 0x05e60da0 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x05e61332 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#34 0x06192bc0 in QSocketNotifier::activated ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#35 0x05e7be25 in QSocketNotifier::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#36 0x05e02249 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#37 0x05e023da in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#38 0x07602378 in KApplication::notify () from /usr/lib/libkdecore.so.4
#39 0x05df6704 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#40 0x05db258e in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#41 0x05e17875 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#42 0x05e177ce in QEventLoop::exec () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#43 0x05e0144b in QApplication::exec () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#44 0x0804a2f8 in ?? ()
#45 0xbfea07e0 in ?? ()
#46 0xbfea06f0 in ?? ()
#47 0x00000000 in ?? ()
Comment 8 Nigel Horne 2005-04-09 03:05:46 EDT
Still occurs and it's months now since a fix was promised.

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208207680 (LWP 365)]
[KCrash handler]
#4  0x016d2543 in QListViewItem::parent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#5  0x0052a415 in KMHeaders::msgHeaderChanged ()
   from /usr/lib/libkmailprivate.so.0
#6  0x00539e53 in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so.0
#7  0x015fa097 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#8  0x00563286 in KMFolder::msgHeaderChanged ()
   from /usr/lib/libkmailprivate.so.0
#9  0x00563626 in KMFolder::qt_emit () from /usr/lib/libkmailprivate.so.0
#10 0x015fa18b in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x0057e1e6 in FolderStorage::msgHeaderChanged ()
   from /usr/lib/libkmailprivate.so.0
#12 0x0057e24b in FolderStorage::headerOfMsgChanged ()
   from /usr/lib/libkmailprivate.so.0
#13 0x005d1679 in KMMsgBase::setStatus () from /usr/lib/libkmailprivate.so.0
#14 0x0049fdde in KMMessage::setStatus () from /usr/lib/libkmailprivate.so.0
#15 0x004a0535 in KMMessage::updateAttachmentState ()
   from /usr/lib/libkmailprivate.so.0
#16 0x004a0966 in KMMessage::fromDwString ()
   from /usr/lib/libkmailprivate.so.0
#17 0x004a0a4f in KMMessage::fromByteArray ()
   from /usr/lib/libkmailprivate.so.0
#18 0x006be489 in KMail::ImapJob::slotGetMessageResult ()
   from /usr/lib/libkmailprivate.so.0
#19 0x006c15e1 in KMail::ImapJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so.0
#20 0x015fa10e in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x011112dd in KIO::Job::result () from /usr/lib/libkio.so.4
#22 0x01111350 in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#23 0x0111395e in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#24 0x01122455 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#25 0x01112a44 in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#26 0x015fa10e in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x015fa7e4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x0110000c in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#29 0x01102c06 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#30 0x01101801 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#31 0x010fd7d6 in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#32 0x010fdb5f in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#33 0x015fa10e in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#34 0x015fa6a0 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#35 0x0192d7d0 in QSocketNotifier::activated ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#36 0x01615235 in QSocketNotifier::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#37 0x0159b539 in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#38 0x0159b6ca in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#39 0x03e4c3b8 in KApplication::notify () from /usr/lib/libkdecore.so.4
#40 0x0158f9f2 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#41 0x0154b6ae in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#42 0x015b0b85 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#43 0x015b0ade in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#44 0x0159a73b in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#45 0x0804a2f8 in ?? ()
#46 0xbfebbb20 in ?? ()
#47 0xbfebba30 in ?? ()
#48 0x00000000 in ?? ()
Comment 9 Ngo Than 2006-05-03 10:32:59 EDT
The new KDE-3.5.2 includes the correct fix for this problem. You should please
update to FC5 current release. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.