Bug 1414578 - Importing of VM from VmWare fails with a confusing message
Summary: Importing of VM from VmWare fails with a confusing message
Keywords:
Status: CLOSED DUPLICATE of bug 1395629
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: future
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-18 21:23 UTC by jniederm
Modified: 2017-01-19 07:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-19 07:25:15 UTC
oVirt Team: Virt


Attachments (Terms of Use)
import-dialog-screenshot.png (47.76 KB, image/png)
2017-01-18 21:23 UTC, jniederm
no flags Details
logs generated between "ok" button was clicked and the error message appeared (3.50 KB, text/plain)
2017-01-18 21:25 UTC, jniederm
no flags Details
complete-logs.zip (4.25 MB, application/zip)
2017-01-18 21:30 UTC, jniederm
no flags Details

Description jniederm 2017-01-18 21:23:37 UTC
Created attachment 1242286 [details]
import-dialog-screenshot.png

Description of problem:
I tried to import a VM from VmWare and it failed. The error message is very confusing. It states:

> All chosen VMs couldn't be retrieved by the external system and therefore  have been filtered. Please see log for details.

* It says "have been filtered". If it means filtered from the right column of selected VMs below (see screenshot) then there is a bug because the only selected VM was still there. If it means filtered from the import procedure, then I'd like to to see something like "filtered from import procedure" to avoid doubts.
* List of names of failing VMs or missing, or the failing VMs are not marked in any way.
* Me message refers to a "log". I guess that it means engine log. It would be nice to be explicit because it also might be host log (or even "Events" window at the bottom of webadmin).
* None of engine log, host log or "Events" window contained any hint why the import have failed.

Version-Release number of selected component (if applicable):
4.2 master, commit 461eb97

How reproducible:
100% if there is non-importable VM in a Vmware

Steps to Reproduce:
1. main tab VMs > click "Import" toolbar button
2. fill in VmWare instance, click load
3. move non-importable VM to the second column, click ok

Actual results:
* Message is shown, but it's ambiguous
* No log message relates to the import failure

Expected results:
* user can recognize what vms failed
* user knows what log to check
* that log actually contains something relevant
* message unambiguously states if "filtered" relates only to import or also to deletion from the second column in the UI

Additional info:

Comment 1 jniederm 2017-01-18 21:25:51 UTC
Created attachment 1242287 [details]
logs generated between "ok" button was clicked and the error message appeared

Comment 2 jniederm 2017-01-18 21:30:07 UTC
Created attachment 1242289 [details]
complete-logs.zip

Comment 3 Tomas Jelinek 2017-01-19 07:25:15 UTC
Marking as duplicate of 1395629 and inside adding a note that this also should be considered so we will have all remarks under one bug.

*** This bug has been marked as a duplicate of bug 1395629 ***


Note You need to log in before you can comment on or make changes to this bug.