Bug 1414607 - Two sets of form buttons on cloud instance retirement
Summary: Two sets of form buttons on cloud instance retirement
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Brian McLaughlin
QA Contact: Dave Johnson
URL:
Whiteboard: ui:button:retirement
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 01:29 UTC by Mike Shriver
Modified: 2017-02-07 04:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-25 15:53:30 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of set retirement (184.34 KB, image/png)
2017-01-19 01:29 UTC, Mike Shriver
no flags Details

Description Mike Shriver 2017-01-19 01:29:44 UTC
Created attachment 1242319 [details]
Screenshot of set retirement

Description of problem:
The Cloud Instance Set Retirement page has two sets of buttons, one with save/cancel and one with save/reset/cancel.

Both cancel buttons work but only one save button, the one in the save/cancel pair, gets enabled and works.

Version-Release number of selected component (if applicable):
5.7.0.17

How reproducible:
Chrome 55.0.2883.87 

Steps to Reproduce:
1.View Set Retirement Date page for a cloud instance

Comment 2 Dave Johnson 2017-01-23 15:39:54 UTC
Mike, does the ui blow up with either button set.  We are thinking that the save button might stay greyed out but curious if the cancel buttons work from either button render.

Comment 3 Mike Shriver 2017-01-23 16:09:58 UTC
I'm at the moment unable to reproduce this bug, it may have been related to my browser cache state.

That being said, when I observed the bug the first time:

Button set 1: Save + Cancel, immediately below form
    - Save button gets enabled/disabled with form validation, cancel button works

Button set 2: Save + Reset + Cancel, bottom of view
    - Save/Reset were never enabled, Cancel button works.

Comment 4 Brian McLaughlin 2017-01-25 15:53:30 UTC
I'm unable to reproduce this bug, tried with latest upstream and a 5.7.0.17 appliance using Chrome/Chromium 55.0.2883.87 (various cache states as well).


Note You need to log in before you can comment on or make changes to this bug.