Bug 1414614 - MYQL Persistant deployment failed consecutively
Summary: MYQL Persistant deployment failed consecutively
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Deployments
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Abhishek Gupta
QA Contact: yasun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 02:24 UTC by Aravind
Modified: 2017-01-24 05:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 05:13:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Deployment overview (88.79 KB, image/png)
2017-01-19 02:24 UTC, Aravind
no flags Details

Description Aravind 2017-01-19 02:24:58 UTC
Created attachment 1242322 [details]
Deployment overview

Description of problem:
MYSQL PERSISTENT



Version-Release number of selected component (if applicable):


How reproducible:
Install MY SQL persistant in openshift next gen console

Steps to Reproduce:
1. Create A new project
2. Choose Mysql persistant.
3.Provide necessary root username and passwords and then submit. The deployment will get failed.

Actual results:
error: update acceptor rejected mysql-3: pods for deployment "mysql-3" took longer than 600 seconds to become ready

Expected results:
MSQL instance must be created

Additional info:
Arrached screenshot of the deployment

Comment 1 Michal Fojtik 2017-01-19 09:45:26 UTC
Do you have any volumes created the deployment can claim? Also can you check the events log for the deployment to investigate what went wrong?

Comment 2 Aravind 2017-01-20 03:57:09 UTC
Hi Michal,
    I have created a volume of 1GB RWO (Read-Write-Once) for deployment claim. 

Below is the error log :

Error creating load balancer (will retry): Error getting LB for service sampls/mysql: Throttling: Rate exceeded status code: 400, request id: 6cc2d523-deba-11e6-b001-935cf9d31392

Comment 4 Abhishek Gupta 2017-01-23 17:26:44 UTC
The Online platform was upgraded last week after you filed the bug. Can you try to redeploy and see if this is still reproducible?

Comment 5 Aravind 2017-01-24 05:13:47 UTC
The error was due to environment upgrade. Now it is working as expected.


Note You need to log in before you can comment on or make changes to this bug.