Bug 141465 - We can not install RHEL4-Beta2.
We can not install RHEL4-Beta2.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 142797 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 05:52 EST by L3support
Modified: 2015-01-04 17:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 03:21:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-12-01 05:52:14 EST
Description of problem:

We tried to install RHEL4-Beta2,
but we can not install it.

We can not use keyboard,
when it displayed "CD Found" screen.
(That is, input was not received)

We can use keyboard,
when we installed RHEL4-Beta1 until "CD Found" screen is displayed.

So, we think problem is not hardware(keyboard).

Having tried is as follows.
 - boot option "ELILO boot:(blank)" and "ELILO boot:linux noprobe"  
 - Installed RHEL4-Beta1 until "CD Found" screen is displayed. 
   (we can use keyboard.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RHEL4-Beta2.
2.
3.
  
Actual results:
We can not install RHEL4-Beta2.

Expected results:
We can install RHEL4-Beta2.


Additional info:

Our PC is running on RHEL3.
Comment 1 Jeremy Katz 2004-12-01 14:24:11 EST
Please provide more information about the hardware you're trying to
install on?

And the keyboard just stops working once it gets to the "CD found"
screen?  Can you switch ttys at that point?
Comment 2 L3support 2004-12-01 21:54:58 EST
The keyboard just stops working once it gets to the "CD found"
screen. 

we tried to siwitch ttys is as following.
 - switch keyboard.
 - The place which puts keyboard is changed.
 - When the keyboard stops working, we removed/connected the keyboard.

 [etc]
 - rewrite install CD.
 
Information about the hardware is as following.
 - keyboard: Option(with PS2 -> USB conversion adapte)
 - CPU     : Itanium2 Processor 1.5GHz/6MB
 - Memory  : 4GB   
 - Chipset : Intel E8870
   
Could you tell me what hardware information you need ?(if any)
Comment 3 Dave Jones 2004-12-02 00:12:29 EST
what type of cd drive is this ? IDE ? SCSI ? 

paste dmesg please.
Comment 5 L3support 2004-12-02 05:55:25 EST
Thank you for your quick comment.

Type of cd drive is IDE.

Information of "dmesg" is as following.

[Begin]-------------------------------------------------

Linux version 2.4.21-15.EL (bhcompile@bullwinkle.build.redhat.com)
(gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-34)) #1 SMP Thu Apr
22 00:13:07 EDT 2004
EFI v1.10 by INTEL: SALsystab=0x7fe4c8c0 ACPI=0x7ff95000 ACPI
2.0=0x7ff94000 MPS=0x7ff93000 SMBIOS=0xf0000
CPU 0: mapping PAL code [0x7fe00000-0x7fe40000) into
[0xe00000007f000000-0xe000000080000000)
efi.trim_bottom: ignoring 24KB of memory at 0x1000 due to granule hole
at 0x0
efi.trim_bottom: ignoring 8KB of memory at 0x7000 due to granule hole
at 0x0
efi.trim_bottom: ignoring 484KB of memory at 0x9000 due to granule
hole at 0x0
efi.trim_bottom: ignoring 4KB of memory at 0x84000 due to granule hole
at 0x0
efi.trim_bottom: ignoring 108KB of memory at 0x85000 due to granule
hole at 0x0
efi.trim_bottom: ignoring 15360KB of memory at 0x100000 due to granule
hole at 0x0
Initial ramdisk at: 0xe0000001fedf1000 (1323008 bytes)
SAL v3.01: oem=Intel Corp                      , product=SR870BN4    
                   
SAL: entry: pal_proc=0x7fe08010, sal_proc=0x7fe48020
SAL: Platform features BusLock IRQ_Redirection 
SAL: AP wakeup using external interrupt vector 0xf0
booting generic kernel on platform dig
CPU 0: 61 virtual and 50 physical address bits
ACPI: RSDP (v002 INTEL                      ) @ 0x000000007ff94000
ACPI: XSDT (v001 INTEL  SR870BN4 00263.08194) @ 0x000000007ff94090
ACPI: FADT (v003 INTEL  SR870BN4 00263.08194) @ 0x000000007ff94138
ACPI: MADT (v001 INTEL  SR870BN4 00263.08194) @ 0x000000007ff94230
ACPI: DSDT (v001  Intel SR870BN4 00000.00000) @ 0x0000000000000000
ACPI: Local APIC address 0xc0000000fee00000
ACPI: LSAPIC (acpi_id[0x00] lsapic_id[0xc0] lsapic_eid[0x18] enabled)
CPU 0 (0xc018) enabled (BSP)
ACPI: LSAPIC (acpi_id[0x01] lsapic_id[0xc2] lsapic_eid[0x18] enabled)
CPU 1 (0xc218) enabled
ACPI: LSAPIC (acpi_id[0x02] lsapic_id[0xaa] lsapic_eid[0x00] disabled)
CPU 2 (0xaa00) disabled
ACPI: LSAPIC (acpi_id[0x03] lsapic_id[0xaa] lsapic_eid[0x00] disabled)
CPU 3 (0xaa00) disabled
ACPI: IOSAPIC (id[0x0] global_irq_base[0x0] address[00000000fec00000])
iosapic_init: Disabling PC-AT compatible 8259 interrupts
IOSAPIC: version 2.0, address 0xfec00000, GSIs 0x0-0x17
ACPI: IOSAPIC (id[0x1] global_irq_base[0x18] address[00000000fec10000])
iosapic_init: Disabling PC-AT compatible 8259 interrupts
IOSAPIC: version 2.0, address 0xfec10000, GSIs 0x18-0x2f
ACPI: IOSAPIC (id[0x2] global_irq_base[0x30] address[00000000fec20000])
iosapic_init: Disabling PC-AT compatible 8259 interrupts
IOSAPIC: version 2.0, address 0xfec20000, GSIs 0x30-0x47
ACPI: IOSAPIC (id[0x3] global_irq_base[0x48] address[00000000fec30000])
iosapic_init: Disabling PC-AT compatible 8259 interrupts
IOSAPIC: version 2.0, address 0xfec30000, GSIs 0x48-0x5f
ACPI: IOSAPIC (id[0x4] global_irq_base[0x60] address[00000000fec40000])
iosapic_init: Disabling PC-AT compatible 8259 interrupts
IOSAPIC: version 2.0, address 0xfec40000, GSIs 0x60-0x77
ACPI: IOSAPIC (id[0x5] global_irq_base[0x78] address[00000000fec50000])
iosapic_init: Disabling PC-AT compatible 8259 interrupts
IOSAPIC: version 2.0, address 0xfec50000, GSIs 0x78-0x8f
ACPI: IOSAPIC (id[0x6] global_irq_base[0x90] address[00000000fec60000])
iosapic_init: Disabling PC-AT compatible 8259 interrupts
IOSAPIC: version 2.0, address 0xfec60000, GSIs 0x90-0xa7
ACPI: PLAT_INT_SRC (polarity[0x3] trigger[0x3] type[0x3] id[0x00c0]
eid[0x18] iosapic_vector[0x1e] global_irq[0x16]
PLATFORM int 0x3: GSI 0x16(low,level) -> CPU 0xc018 vector 30
ACPI: INT_SRC_OVR (bus[0] irq[0x9] global_irq[0x9] polarity[0x1]
trigger[0x3])
register_intr: changing vector 39 from IO-SAPIC-edge to IO-SAPIC-level
2 CPUs available, 4 CPUs total
Mca related initialization done
On node 0 totalpages: 260731
zone(0): 262144 pages.
zone(1): 0 pages.
zone(2): 262125 pages.
Virtual mem_map starts at 0xa0007ffffc800000
Kernel command line: BOOT_IMAGE=scsi0:EFI\redhat\vmlinuz-2.4.21-15.EL
 root=LABEL=/ ro
FPSWA interface at 0x1ffe70010, revision 1.18
CPU 0: base freq=199.458MHz, ITC ratio=15/2, ITC freq=1495.938MHz
Console: colour VGA+ 80x25
Calibrating delay loop... 2241.08 BogoMIPS
Memory: 4115664k/4171696k available (4212k code, 39648k reserved,
3455k data, 368k init)
Dentry cache hash table entries: 262144 (order: 8, 4194304 bytes)
Inode cache hash table entries: 262144 (order: 8, 4194304 bytes)
Mount cache hash table entries: 1024 (order: 0, 16384 bytes)
Buffer cache hash table entries: 262144 (order: 7, 2097152 bytes)
Page-cache hash table entries: 262144 (order: 7, 2097152 bytes)
POSIX conformance testing by UNIFIX
Boot processor id 0x0/0xc018
SMP: starting up secondaries.
CPU 1: mapping PAL code [0x7fe00000-0x7fe40000) into
[0xe00000007f000000-0xe000000080000000)
CPU 1: 61 virtual and 50 physical address bits
CPU 1: synchronized ITC with CPU 0 (last diff 4 cycles, maxerr 540 cycles)
CPU 1: base freq=199.458MHz, ITC ratio=15/2, ITC freq=1495.938MHz
CPU 1: checking for saved MCA error records
Calibrating delay loop... 2241.08 BogoMIPS
allocating GDT on cpu: 1
CPU1: CPU has booted.
Before bogomips.
Total of 2 processors activated (4482.16 BogoMIPS).
Starting migration thread for cpu 0
Starting migration thread for cpu 1
ACPI: Subsystem revision 20030619
PCI: Using SAL to access configuration space
ACPI: Interpreter enabled
ACPI: Using IOSAPIC for interrupt routing
ACPI: System [ACPI] (supports S0 S4 S5)
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Ignoring BAR0-3 of IDE controller 00:1f.1
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.H2PB._PRT]
ACPI: PCI Root Bridge [PCI1] (00:02)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI1.P2PA._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI1.P2PB._PRT]
ACPI: PCI Root Bridge [PCI3] (00:09)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI3.P2PA._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI3.P2PB._PRT]
ACPI: PCI Root Bridge [PCI4] (00:0f)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI4.P2PA._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI4.P2PB._PRT]
CPU 0: checking for saved MCA error records
PCI->APIC IRQ transform: (00:1d.0 INTA) -> CPU 0xc018 vector 48
PCI->APIC IRQ transform: (00:1d.1 INTB) -> CPU 0xc018 vector 49
PCI->APIC IRQ transform: (00:1d.7 INTD) -> CPU 0xc018 vector 50
PCI: no interrupt route for 00:00:1f pin A
PCI->APIC IRQ transform: (01:00.0 INTA) -> CPU 0xc018 vector 51
PCI->APIC IRQ transform: (03:1f.0 INTA) -> CPU 0xc018 vector 52
PCI->APIC IRQ transform: (06:02.0 INTA) -> CPU 0xc018 vector 53
PCI->APIC IRQ transform: (06:02.1 INTB) -> CPU 0xc018 vector 54
PCI->APIC IRQ transform: (06:1f.0 INTA) -> CPU 0xc018 vector 55
PCI->APIC IRQ transform: (0a:1f.0 INTA) -> CPU 0xc018 vector 56
PCI->APIC IRQ transform: (0c:1f.0 INTA) -> CPU 0xc018 vector 57
PCI->APIC IRQ transform: (10:01.0 INTA) -> CPU 0xc018 vector 58
PCI->APIC IRQ transform: (10:01.1 INTB) -> CPU 0xc018 vector 59
PCI->APIC IRQ transform: (10:1f.0 INTA) -> CPU 0xc018 vector 60
PCI->APIC IRQ transform: (11:1f.0 INTA) -> CPU 0xc018 vector 61
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
perfmon: version 1.3 IRQ 238
perfmon: 16 PMCs, 18 PMDs, 4 counters (47 bits)
PAL Information Facility v0.5
EFI Variables Facility v0.05 2002-Mar-26
Total HugeTLB memory allocated, 0
Starting kswapd
allocated 32 pages and 32 bhs reserved for the highmem bounces
VFS: Disk quotas vdquot_6.5.1
aio_setup: num_physpages = 65182
aio_setup: sizeof(struct page) = 112
Hugetlbfs mounted.
initialize_kbd: Keyboard reset failed, no ACK
pty: 2048 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT
SHARE_IRQ DETECT_IRQ SERIAL_PCI SERIAL_ACPI enabled
ttyS0 at 0x03f8 (irq = 44) is a 16550A
ttyS1 at 0x02f8 (irq = 45) is a 16550A
register_serial(): autoconfig failed
register_serial(): autoconfig failed
EFI Time Services Driver v0.4
NET4: Frame Diverter 0.46
RAMDISK driver initialized: 256 RAM disks of 8192K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
ICH4: IDE controller at PCI slot 00:1f.1
PCI: Device 00:1f.1 not available because of resource collisions
PCI: Found IRQ 0 for device 00:1f.1
ICH4: Not fully BIOS configured!
ICH4: chipset revision 2
ICH4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1000-0x1007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x1008-0x100f, BIOS settings: hdc:pio, hdd:pio
hda: MATSHITADVD-ROM SR-8177, ATAPI CD/DVD-ROM drive
global_restore_flags: 10084a6010 (e000000004988770)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 34
ide-floppy driver 0.99.newide
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 65536 buckets, 1024Kbytes
TCP: Hash tables configured (established 2097152 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
Initializing IPsec netlink socket
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 1280kB freed
VFS: Mounted root (ext2 filesystem).
SCSI subsystem driver Revision: 1.00
Fusion MPT base driver 2.05.11.03
Copyright (c) 1999-2003 LSI Logic Corporation
PCI: Found IRQ 53 for device 06:02.0
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator}
PCI: Found IRQ 54 for device 06:02.1
mptbase: Initiating ioc1 bringup
ioc1: 53C1030: Capabilities={Initiator}
mptbase: 2 MPT adapters found, 2 installed.
Fusion MPT SCSI Host driver 2.05.11.03
scsi0 : ioc0: LSI53C1030, FwRev=01030a00h, Ports=1, MaxQ=255, IRQ=53
scsi1 : ioc1: LSI53C1030, FwRev=01030a00h, Ports=1, MaxQ=255, IRQ=54
blk: queue e00000007f78b130, I/O limit 17592186044415Mb (mask
0xffffffffffffffff)
  Vendor: FUJITSU   Model: MAP3367NC         Rev: 5207
  Type:   Direct-Access                      ANSI SCSI revision: 03
blk: queue e00000007f78ad30, I/O limit 17592186044415Mb (mask
0xffffffffffffffff)
  Vendor: ESG-SHV   Model: SCA HSBP M17      Rev: 1.0A
  Type:   Processor                          ANSI SCSI revision: 02
blk: queue e00000007f78a930, I/O limit 17592186044415Mb (mask
0xffffffffffffffff)
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 71390320 512-byte hdwr sectors (36552 MB)
Partition check:
 sda: sda1 sda2 sda3
Journalled Block Device driver loaded
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 368kB freed
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 00:25:23 Apr 22 2004
usb-uhci.c: High bandwidth mode enabled
PCI: Found IRQ 48 for device 00:1d.0
usb-uhci.c: USB UHCI at I/O 0x4cc0, IRQ 48
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Found IRQ 49 for device 00:1d.1
usb-uhci.c: USB UHCI at I/O 0x4ce0, IRQ 49
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
PCI: Found IRQ 50 for device 00:1d.7
ehci-hcd 00:1d.7: Intel Corp. 82801DB USB2
ehci-hcd 00:1d.7: irq 50, pci mem c0000000f9ff0000
usb.c: new USB bus registered, assigned bus number 3
ehci-hcd 00:1d.7: enabled 64bit PCI DMA
PCI: 00:1d.7 PCI cache line size set incorrectly (0 bytes) by BIOS/FW.
PCI: 00:1d.7 PCI cache line size corrected to 128.
ehci-hcd 00:1d.7: USB 2.0 enabled, EHCI 1.00, driver 2003-Jan-22
hub.c: USB hub found
hub.c: 4 ports detected
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
EXT3 FS 2.4-0.9.19, 19 August 2002 on sd(8,2), internal journal
Adding Swap: 2097120k swap-space (priority -1)
hub.c: new USB device 00:1d.1-2, assigned address 2
input0: USB HID v1.10 Keyboard [Composite USB PS2 Converter USB to PS2
Adaptor  v1.12] on usb2:2.0
input1: USB HID v1.10 Mouse [Composite USB PS2 Converter USB to PS2
Adaptor  v1.12] on usb2:2.1
usb-uhci.c: ENXIO 84000280, flags 0, urb e00000007ef63880, burb
e00000007ef63d80
usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 18 ret -6
usb-uhci.c: ENXIO 84000280, flags 0, urb e00000007ef63880, burb
e00000007ef63d80
usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 18 ret -6
usb-uhci.c: ENXIO 84000280, flags 0, urb e00000007ef63880, burb
e00000007ef63d80
usbdevfs: USBDEVFS_CONTROL failed dev 2 rqt 128 rq 6 len 18 ret -6
Attached scsi generic sg1 at scsi0, channel 0, id 6, lun 0,  type 3
Intel(R) PRO/1000 Network Driver - version 5.2.30.1-k1
Copyright (c) 1999-2004 Intel Corporation.
PCI: Found IRQ 51 for device 01:00.0
divert: allocating divert_blk for eth0
eth0: Intel(R) PRO/1000 Network Connection
PCI: Found IRQ 58 for device 10:01.0
divert: allocating divert_blk for eth1
eth1: Intel(R) PRO/1000 Network Connection
PCI: Found IRQ 59 for device 10:01.1
divert: allocating divert_blk for eth2
eth2: Intel(R) PRO/1000 Network Connection
divert: freeing divert_blk for eth0
divert: freeing divert_blk for eth1
divert: freeing divert_blk for eth2
ip_tables: (C) 2000-2002 Netfilter core team
Intel(R) PRO/1000 Network Driver - version 5.2.30.1-k1
Copyright (c) 1999-2004 Intel Corporation.
PCI: Found IRQ 51 for device 01:00.0
divert: allocating divert_blk for eth0
eth0: Intel(R) PRO/1000 Network Connection
PCI: Found IRQ 58 for device 10:01.0
divert: allocating divert_blk for eth1
eth1: Intel(R) PRO/1000 Network Connection
PCI: Found IRQ 59 for device 10:01.1
divert: allocating divert_blk for eth2
eth2: Intel(R) PRO/1000 Network Connection
ip_tables: (C) 2000-2002 Netfilter core team
e1000: eth0 NIC Link is Up 100 Mbps Full Duplex
ACPI: Power Button (FF) [PWRF]

[End]---------------------------------------------------
Comment 6 L3support 2004-12-05 20:08:44 EST
Could you close this problem ?

We can install RHEL-Beta2,
when we tried to install many times. 

Detail is as following.

Keyboard can work,
when we tried to do "ELILO boot:linux askmethod".
We reboot, we did "ELILO boot:(blank)".
Then, keyboard can work.
So, we can install.

We guess that problem is hardware environment.
Because we did nothing about software.

If you can guess cause, please teach us.
Comment 8 Jay Turner 2004-12-14 03:49:49 EST
*** Bug 142797 has been marked as a duplicate of this bug. ***
Comment 9 L3support 2004-12-20 21:01:00 EST
Could you tell me status of problem ?
Comment 10 L3support 2005-01-05 02:32:54 EST
When we run "ELILO boot:linux noprobe" in order to install RHEL-Beta2,
keyboard can not work at "CD Found" screen. (Bug 142797)

We would like to know the behavior is feature or bug.
Comment 11 RHEL4-L3support 2005-01-18 20:54:27 EST
Add RHEL4-L3support team in Japan
Comment 12 Jay Turner 2005-01-19 08:17:40 EST
I suspect that the 'linux noprobe' boot command isn't loading the USB drivers
which are necessary to utilize the keyboard.  If this is what's happening, then
this isn't a bug.
Comment 13 JoAnne K. Halligan 2005-01-23 17:16:05 EST
Can Fujitsu confirm this problem still occurs on RHEL4 RC and re-state clearly
what the exact problem and specific failure is? Is this still a problem or per
Jay Turners comment above, should this be closed as 'not a bug'. 

Thanks, JoAnne

Comment 14 L3support 2005-02-24 03:21:39 EST
We do not specify "linux noprobe" when we use USB keyboard and mouse. 

Note You need to log in before you can comment on or make changes to this bug.