Bug 141474 - X freezes with synaptics touchpad
X freezes with synaptics touchpad
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 07:59 EST by Hernan Petitti
Modified: 2013-03-13 02:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.6.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 08:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hernan Petitti 2004-12-01 07:59:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
X freezes (screen and no keyboard) when I only use touchpad (no usb
mouse attached). Even when I change some modules such as synaptics or
mouse in /etc/X11/xorg.conf
But touchpad works fine if a usb mouse is connected.



Version-Release number of selected component (if applicable):
synaptics--0.13.5-5

How reproducible:
Always

Steps to Reproduce:
1. boot in runlevel 3 (it hangs in runlevel 5 with gdm too)
2. xinit or startx
3. move the mouse pointer and/or press some keys and wait a few
seconds to see it.
    

Actual Results:  Screen freezes, keyboard not respond and touchpad
still working.

Expected Results:  Still using touchpad without crashes.

Additional info:

HP pavilion ze5165.
If a usb mouse is connected, touchpad works fine (usb mouse too) and X
no crashes.
With Fedora Core 2 works perfect using "psmouse" module in
/etc/X11/XF86Config and "psmouse.proto=imps" in grub.conf

# cat /proc/bus/input/devices
I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
H: Handlers=kbd event0
B: EV=120013
B: KEY=4 2000000 3802078 f840d001 f2ffffdf ffefffff ffffffff fffffffe
B: MSC=10
B: LED=7

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
H: Handlers=mouse0 event1
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103

I: Bus=0003 Vendor=09da Product=0006 Version=0001
N: Name="A4Tech USB Optical Mouse"
P: Phys=usb-0000:00:0f.0-1/input0
H: Handlers=mouse1 event2
B: EV=7
B: KEY=7f0001 0 0 0 0 0 0 0 0
B: REL=143
Comment 1 Mike A. Harris 2005-02-01 00:48:20 EST
Reassigning to "synaptics" component.
Comment 2 Paul Nasrat 2005-02-01 10:45:26 EST
Please attach your Xorg.conf and the X logfile as seperate non
compressed attachements.
Comment 3 Hernan Petitti 2005-02-10 08:00:57 EST
Apparently the problem was solved with kernel 2.6.10 or newer, because
X didn't crash again.

Note You need to log in before you can comment on or make changes to this bug.