Bug 141475 - bad accents on some apps like lyx
bad accents on some apps like lyx
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 08:45 EST by Jose L.
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 11:34:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bad accents on lyx (30.00 KB, image/jpeg)
2004-12-09 02:19 EST, Jose L.
no flags Details

  None (edit)
Description Jose L. 2004-12-01 08:45:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Accents in Lyx and others programs appear NEXT to vowels; they work OK
in OOffice.
<a href="http://bugs.kde.org/show_bug.cgi?id=88151">Look this
reference</a> please

Version-Release number of selected component (if applicable):
kernel 2.6.0-1, kde 3.3.1-2.2, qt-3.3.3-8, lyx-1.3.5-1.1.fc3.rf

How reproducible:
Always

Steps to Reproduce:
1.Run Lyx
2.
3.
    

Additional info:
Comment 1 Rex Dieter 2004-12-01 08:55:57 EST
FYI, koffice suffers the same problem.  

IMO, this bug should be assigned to qt, as it is the immodule patch
responsible.  Disabling immodule makes things work again.
Comment 2 Rex Dieter 2004-12-01 09:03:05 EST
Jose, 
you could try moving/renaming
/usr/lib/qt-3.3/plugins/inputmethods
to see if that helps.
Comment 3 Jose L. 2004-12-01 09:27:25 EST
How could i disable the immodule?
I try moving and renaming that directory and don't solve the problem :(
Comment 4 Rex Dieter 2004-12-01 09:36:21 EST
The only way to completely disable immodule is to rebuild qt without 
the immodule patch.

You could try the qt rpms from 
http://kde-redhat.sf.net/
which has immodule disabled (primarily due to this bug).
Comment 5 Jose L. 2004-12-01 12:50:10 EST
Hi again,
I have installed FC2 and the problem dissapear:
Kernel 2.6.5-1.358 KDE 3.2.2-4 qt 3.3.2-2 and lyx 1.3.5-1.1
Comment 6 Rex Dieter 2004-12-01 13:05:22 EST
FYI, from qt's changelog:
* Thu Jul 01 2004 Than Ngo <than@redhat.com> 1:3.3.2-10
- add immodule for Qt

Looks like immodule wasn't added until later.
Comment 7 Jose L. 2004-12-02 09:22:34 EST
Actually I have:
Kernel 2.6.9-1.6_FC2, KDE 3.2.2.-8.FC2, qt-3.3.3-0.1 and
lyx-1.3.5-1.1.fc2.dag.
With those components works fine; maybe with KDE 3.3 fail?
Comment 8 Rex Dieter 2004-12-02 09:25:53 EST
I doubt kde has anything to do with it as lyx is a qt-only program.
Comment 9 Jose L. 2004-12-02 09:28:33 EST
Do you think that qt is the problem?
Comment 10 Rex Dieter 2004-12-02 09:30:37 EST
Yes, qt and the immodule patch is the problem.  That's what I've been
saying the whole time.
Comment 11 Jose L. 2004-12-02 09:37:26 EST
I don't know what is the immodule; On qt site don't speak about this
problem or similar
Comment 12 Rex Dieter 2004-12-02 09:47:17 EST
FYI,
http://freedesktop.org/Software/ImmoduleQtDownload/
Comment 13 Rex Dieter 2004-12-02 09:52:16 EST
Sorry, here's a better link:
http://freedesktop.org/wiki/Software/immodule-qt
Comment 14 Jose L. 2004-12-02 11:09:40 EST
I have sent a mail to immodule-qt@freedesktop.org, explain the
problem; waiting ...
Comment 15 Rex Dieter 2004-12-02 13:57:47 EST
I've confirmed qt-3.3.3-15 still exhibits the same (bad) behavior. 
dead-keys do not function properly in either kword or lyx.

One can at least copy-n-paste in accented characters into kword. 
Pasting accented characters into lyx generates bogus/garbage looking
output.
Comment 16 Leon Ho 2004-12-08 20:17:12 EST
Can you try if:
# export QT_IM_MODULE=simple
before running the application helps?
Comment 17 Jose L. 2004-12-09 02:19:02 EST
Created attachment 108181 [details]
bad accents on lyx

Don't function export qt.... see
Comment 18 Jose L. 2005-01-31 02:43:25 EST
Please redhat team (Ngo Than), what's happen? any solution? any ...?
Comment 19 Persio Barros 2005-02-07 05:45:36 EST
I got the qt package from the kde-redhat project from:
ftp://apt.kde-redhat.org/apt/kde-redhat/fedora/3/stable/RPMS/qt-3.3.3-16.3.3.kde.i386.rpm
After installing it, the accents in lyx are now working as expected.
But I don't know if this will have any impact on other programs. May
be on KDE? Well, I use gnome.
Comment 20 Jose L. 2005-02-07 05:53:55 EST
Great! Works fine, by now. Thanks
Comment 21 Leon Ho 2005-02-07 10:57:08 EST
It look like we have to fix lyx. Please see:
http://lists.freedesktop.org/arhives/immodule-qt/2004-December/000649.html

We do not include lyx. Any pointer on upstream contacts, or anyone
have tried to talk to the upstream about it?
Comment 22 Michael Schwendt 2005-02-07 11:26:47 EST
Fixed link:
http://lists.freedesktop.org/archives/immodule-qt/2004-December/000649.html

lyx is included in Fedora Extras.
Comment 23 Jose L. 2005-02-07 13:44:51 EST
With the new version of qt package (3.3.3.-16.3.3) everything works fine.
Comment 24 Ngo Than 2005-02-11 11:34:46 EST
i think lyx needs to be fixed in this case! and Kazuki is willing to
fix this problem in lyx.
Comment 25 Rex Dieter 2005-02-11 11:50:26 EST
FYI, koffice is busted too.
Comment 26 Ngo Than 2005-02-12 09:01:22 EST
i have done the backport for koffice-1.3.5-3. It now fixes this problem.
Please don't forget to update qt-3.3.4-4, which is required for this.
Comment 27 Rex Dieter 2005-02-12 11:48:57 EST
Thanks Ngo, fabulous!

Note You need to log in before you can comment on or make changes to this bug.