Bug 1414809 - problem in F25 shutdown process
Summary: problem in F25 shutdown process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-19 14:06 UTC by joerg.lechner
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-14 14:39:44 UTC
Type: Bug


Attachments (Terms of Use)

Description joerg.lechner 2017-01-19 14:06:59 UTC
Description of problem:
is use external disks (USB) to collect TV films and TV shows. Yesterday I forgot to eject the external disk before shutting down F25. Result ratarata...... of the external disk during the shut down process. Currently I have no access to this disk (sata, 1TB) via F25, F24 and Windows I did not try so far.
The shut down process of F25 takes a lot more time, then the shut down process of F24/F23. By Shutting down F25 a lot of code is displayed. I didn't make any modification, the system is as originally installed, with the last updates. This very long lasting shut down process seems to have been the same since Alpha. With F24/F23, the shutdown is quick in F24/F23, I could shutting down the PC without destroying an external disk. My system Acer Laptop E5-571G-50K9, F25 Desktop Version 64bit, the external disk is connected with an USB adapter, it's a used internal disk. I don't know exactly whether the disk has had an error previously or not, but I could save on it about 100GB films, before this damaging shutting down, without of the "ticking" of a moribund disk. The disk was ok before this F25 shutdown happened.

Anyway, I don't cry for this disk, but I think there is a serious error in the shutdown process of the F25 Desktop version. 



Version-Release number of selected component (if applicable):
all kernels at least since F25 Alpha

How reproducible:
always


Steps to Reproduce:
1. shutdown F25 desktop version, and You will see lot of code, while shutting down, which does not appear in F24/F23. The shutdown process of F24/F23 is very quick, as I expected also for F25
2.
3.

Actual results:
shutdown process very time consuming


Expected results:
Quick shutdown process

Additional info:

Comment 1 joerg.lechner 2017-01-24 07:45:40 UTC
As Stan has detected (see thread "Re: problem in F25 shutdown process" in the test Forum), I have now deleted plymouth. The shutdown process is now quick with clear messages, and shows not anymore such worrying messages as was with plymouth in the system. I think Stan has detected the error in the shutdown process.

Comment 2 Justin M. Forbes 2017-04-11 14:47:41 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 3 joerg.lechner 2017-04-17 11:40:00 UTC
I have compared the shutdown times F25 (Kernel 4.10.9-200.fc25) and F24 (Kernel 4.10.9-100.fc24). The F25 shutdown takes more time, in my opinion too much time and for me this issue is currently not solved.

Comment 4 joerg.lechner 2017-04-22 06:47:40 UTC
See the same behaviour in F26 Workstation with Kernel:
Name         : kernel
Version      : 4.11.0
Release      : 0.rc7.git0.1.fc26
Arch         : x86_64

Comment 5 joerg.lechner 2017-04-22 18:33:35 UTC
Comparison of shutdown times F24 -  F26:
F24  ...  8 sec.
F26  ... 17 sec.

Test procedure for F24 and F26 was the same:
boot - start Firefox - do some work for about 3 min. - deactivate Firefox - wait about 2 min. - shutdown.

Comment 6 joerg.lechner 2017-04-28 12:11:07 UTC
F25.... After update to 
Name        : kernel
Arch        : x86_64
Epoch       : 0
Version     : 4.10.12
Release     : 200.fc25

shutdown time reduced to about 9 sec.

Comment 7 Laura Abbott 2018-02-28 03:50:42 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.

Comment 8 joerg.lechner 2018-03-14 13:55:30 UTC
So far did not appear in F27

Comment 9 Laura Abbott 2018-03-14 14:39:44 UTC
Thanks for letting us know. I'm going to close the bug, if you see it again feel free to reopen.


Note You need to log in before you can comment on or make changes to this bug.