Bug 141484 - Kernel 2.6.9 zombie creation when killing debugee
Kernel 2.6.9 zombie creation when killing debugee
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-12-01 10:03 EST by André Johansen
Modified: 2015-01-04 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.12-1.1372_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-03 04:15:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description André Johansen 2004-12-01 10:03:45 EST
When debugging a threaded program with TotalView 
(http://www.etnus.com/), killing the program from the debugger after 
threads have been created creates zombie processes. 
This does not happen on the FC2 2.6.8 kernels. 
It also happens on the 2.6.9 FC2 kernel, so is not specific to FC3. 
This seems to not happen when debugging with GDB. 
I'm guessing that this could be due to some ptrace changes in the 
2.6.9 kernel.
Comment 1 André Johansen 2004-12-01 10:14:45 EST
This has happened on two similar machines, one running FC2 and one 
FC3.  These are old dual P3@1GHz Dell rack machines. 
Kernels tested with the bug: 
kernel-smp-2.6.9-1.667 (FC3) 
Kernels without the bug: 
kernel-smp-2.6.8-1.521 (FC2) 
I'll try the working 2.6.8 kernel on the FC3 machine. 
Comment 2 André Johansen 2004-12-01 10:33:07 EST
With the 2.6.8 FC2 kernel on the FC3 machine, the problem is gone. 
Comment 3 Dave Jones 2005-01-14 02:24:53 EST
fixed in the 2.6.10 updates ?
Comment 4 André Johansen 2005-01-14 09:06:39 EST
With kernel-smp-2.6.10-1.741_FC3, TotalView is still unable to kill the 
process properly (they end up as zombies), but exiting TotalView now removes 
the zombies (which is an improvement). 
So, better, but still not good -- you can't restart the program in the 
Comment 5 André Johansen 2005-07-01 16:10:35 EDT
Recent TotalView versions have a work-around for this problem. 
Comment 6 Dave Jones 2005-07-15 15:17:36 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 André Johansen 2005-07-25 13:22:10 EDT
The first computer I tried this on would not boot (unable to mount the root 
filesystem).  Will try on another later, and report back. 
Comment 8 André Johansen 2005-08-03 04:15:18 EDT
With mkinitrd fixed (mkinitrd-, 2.6.12 now boots, and seems to have 
fixed the issue.

Note You need to log in before you can comment on or make changes to this bug.