Bug 141507 - smartctl dubious output.
smartctl dubious output.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 13:02 EST by David Woodhouse
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 10:43:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2004-12-01 13:02:41 EST
See following output of smartctl on ppc. See the dubious raw values
for stuff like Reallocated_Sector_Ct. That's 0x7d000000000, but
0x000000007d seems like a more reasonable value.

Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE     
UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   100   100   046    Pre-fail 
Always       -       51633
  2 Throughput_Performance  0x0005   100   100   030    Pre-fail 
Offline      -       29360576
  3 Spin_Up_Time            0x0003   100   100   025    Pre-fail 
Always       -       1
  4 Start_Stop_Count        0x0032   099   099   000    Old_age  
Always       -       1940
  5 Reallocated_Sector_Ct   0x0033   100   100   024    Pre-fail 
Always       -       8589934592000
  7 Seek_Error_Rate         0x000f   100   100   047    Pre-fail 
Always       -       3335
  8 Seek_Time_Performance   0x0005   100   100   019    Pre-fail 
Offline      -       0
  9 Power_On_Seconds        0x0032   092   092   000    Old_age  
Always       -       4212h+23m+02s
 10 Spin_Retry_Count        0x0013   100   100   020    Pre-fail 
Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age  
Always       -       1084
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age  
Always       -       124
193 Load_Cycle_Count        0x0032   091   091   000    Old_age  
Always       -       95235
194 Temperature_Celsius     0x0022   100   100   000    Old_age  
Always       -       35 (Lifetime Min/Max 11/44)
195 Hardware_ECC_Recovered  0x001a   100   100   000    Old_age  
Always       -       1970
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age  
Always       -       283377664
197 Current_Pending_Sector  0x0012   100   100   000    Old_age  
Always       -       0
198 Offline_Uncorrectable   0x0010   100   100   000    Old_age  
Offline      -       1
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age  
Always       -       0
200 Multi_Zone_Error_Rate   0x000f   100   100   060    Pre-fail 
Always       -       22981
203 Run_Out_Cancel          0x0002   100   100   000    Old_age  
Always       -       1533283926809
Comment 1 Tomas Mraz 2005-11-29 10:43:44 EST
It looks like the new fujitsu drives (I suppose it is one of them) report some
internal data in high bytes of the raw values of some attributes as
Reallocated_Sector_Count or Reallocated_Event_Count. It isn't endianness issue.
Please report the drive upstream.
smartmontools-support@lists.sourceforge.net
smartmontools-database@lists.sourceforge.net

Note You need to log in before you can comment on or make changes to this bug.