Bug 141570 - anaconda crashes attempting to mount sysimage
anaconda crashes attempting to mount sysimage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
http://wolves.homeip.net/~ggw/texts/a...
:
: 142139 142776 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 00:40 EST by G.Wolfe Woodbury
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 12:57:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2004-12-02 00:40:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Anaconda crashes with an unexpected exception dump during installation
of rawhide on an AMD K6-2.  The dump is at:

http://wolves.homeip.net/~ggw/texts/anacdump.txt


Version-Release number of selected component (if applicable):
anaconda-10.2.0.5-1

How reproducible:
Always

Steps to Reproduce:
1. burn rawhide boot.iso to CD-RW
2. boot, select custom install
3. finish selections and let anaconda proceed
    

Actual Results:  Anaconda produces an exception

Expected Results:  normal installation process

Additional info:

machine specifics:
  AMD K6-2 @380MHz   320MB RAM   Standard IDE disks (20GB 120GB)
     Asus P5A-B mobo             Verbatim CD-R (hdc)
                                 Tulip ethernet 3c509 ethernet
Comment 1 Tim Waugh 2004-12-02 08:20:29 EST
I see this too.
Comment 2 Jeremy Katz 2004-12-08 11:00:49 EST
*** Bug 142139 has been marked as a duplicate of this bug. ***
Comment 3 Carl Worth 2004-12-08 14:29:33 EST
I just hit this as well. And I've got a machine sitting here in the
crashed state if that would be useful.

It's clear that the bind mount fails:

    # mount -o bind /dev /mnt/sysimage/dev
    mount: Mounting /dev on /mnt/sysimage/dev failed: Invalid argument

I doubt that that failure is anaconda's fault, but perhaps it would be
useful for anaconda to cleanly deal with the failure at least until
the underlying bug is fixed?
Comment 4 taj 2004-12-11 13:24:18 EST
I wouldn't know where to start digging through this but:

# mount  /dev /mnt/sysimage/ --bind
# mount |grep sysimage
/dev on /mnt/sysimage type none (rw,bind)
Comment 5 Jeremy Katz 2004-12-13 20:44:31 EST
*** Bug 142776 has been marked as a duplicate of this bug. ***
Comment 6 Jim Cornette 2004-12-13 23:15:47 EST
As an additonal note. This problem happened on the upgrade,
installation with automatic partitioning and with selecting what
partition scheme to use.
The attachment in duplicate bug 142776 shows the anaconda dump text
from the upgrade attempt.
Back to FC3 with a clean installation.
Comment 7 Tim Waugh 2004-12-14 07:24:11 EST
taj: no, you need to run that on VT2 *during* stage2 to see it.

Is this a kernel change or an anaconda problem?  CCing davej..
Comment 8 taj 2004-12-14 08:55:39 EST
I booted a new disk to confirm.  The busybox syntax is indeed different with
regards to -bind.  I also notice on VT2 during stage2 that while bind mounting
/dev with 

     "mount /dev /mnt/sysimage/dev -o bind"

fails, 

     "mount /dev/pts /mnt/sysimage/dev -o bind"


works.  I just tried this because /dev/pts shows as a mount point while /dev
does not.
Comment 9 Jeremy Katz 2004-12-20 12:10:20 EST
This is being caused by bind mounts off of the (initramfs-based)
rootfs not working.

Al -- is this as designed?  If so, I can mount a ramfs on the rootfs
to use for /dev so that I can later bind mount that instead, but I
want to make sure there's not something lingering in the kernel here.
Comment 10 Alexander Viro 2004-12-20 16:23:01 EST
You are not allowed to create bindings *to* rootfs.  You can, of
course, mount ramfs on rootfs's /dev and bind to it, no problems with
that.
Comment 11 Jeremy Katz 2004-12-20 18:17:27 EST
Committed changes so that we should create a tmpfs /dev like on the
installed system.
Comment 12 Joe Orton 2005-01-06 07:07:16 EST
Trying today's Raw Hide I got a traceback saying something like:

"select expects exactly two arguments"

context was select("kernel-devel").  Dunno whether this is before or
after this bug.
Comment 13 G.Wolfe Woodbury 2005-01-10 17:51:07 EST
rawhide of 2005.01.09 works okay
Comment 14 Rahul Sundaram 2005-08-15 12:57:55 EDT
G.Wolfe Woodbury,

Thank you for verifying this

Note You need to log in before you can comment on or make changes to this bug.