Bug 1415838 - XIQueryDevice in XI2 not returning good pointer
Summary: XIQueryDevice in XI2 not returning good pointer
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 21:46 UTC by jane.o.cashin
Modified: 2017-01-25 18:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-25 18:46:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jane.o.cashin 2017-01-23 21:46:09 UTC
Description of problem:
When I call the XInput2 function XIQueryDevice I core dump when I try to access "name" (char *) and classes (XIAnyClassInfo **) from the returned XIDeviceInfoPtr.  I am able to access all the other structure variables in the structure (deviceid, use, attachment, enabled, num_classes).

Version-Release number of selected component (if applicable):
Using Red Hat 7.3

How reproducible:
repeatedly

Steps to Reproduce:
1. Call XIQueryDevice
2. Access the "name" variable from the returned structure
3.

Actual results:
Core dump

Expected results:
Should be able to read the data from the pointer to the structure.

Additional info:

Comment 2 jane.o.cashin 2017-01-25 18:42:56 UTC
I have done more testing and found this to not be a bug.

Comment 3 Tomas Pelka 2017-01-25 18:46:39 UTC
(In reply to jane.o.cashin from comment #2)
> I have done more testing and found this to not be a bug.

Thanks I'm going to close as not a bug.


Note You need to log in before you can comment on or make changes to this bug.