Bug 141589 - post-increments is wreaking havoc on tests
post-increments is wreaking havoc on tests
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: other (Show other bugs)
beta
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
Rob Landry
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 05:34 EST by Jay Turner
Modified: 2015-01-07 19:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-03 12:04:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
USB output.log (2.11 KB, text/x-log)
2004-12-02 05:38 EST, Jay Turner
no flags Details

  None (edit)
Description Jay Turner 2004-12-02 05:34:35 EST
Description of problem:
Definitely not sure what's happening here, but the post-increment actions in the
tests appear to be causing all sorts of chaos.  Post-incrementing appears to
work just fine outside of the rhr2 scripts, so not sure if that really tells us
anything or not.  Specifically the USB tests has lots of issues.  Running
rhr2-rhel4-0.9-14.9e.dummyrun with "USB 2" in the hardware.conf file, I'm seeing
the following (full output.log will be attached):

+ local 'usb_device_map=004/001 "UHCI Host Controller" hub
003/001 "UHCI Host Controller" hub
002/001 "UHCI Host Controller" hub
001/001 "EHCI Host Controller" hub'
+ '[' '' = legacyfree ']'
+ '[' 0 -ge 2 ']'
+ let usb_port++
143802954528413786434447289794254616778

So, I get to the post-increment and then things just exit . . . very weird. 
Changing these from "let <blah>++" to "let <blah>=<blah>+1" fixes the issue and
the window actually pops prompting to plug and unplug the USB devices.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jay Turner 2004-12-02 05:38:21 EST
Created attachment 107758 [details]
USB output.log
Comment 2 Rob Landry 2004-12-02 10:54:09 EST
Turns out that while post increment is working it exits "1" instead of "0" I
submitted this as a bug only to be informed that it's expected behaviour (I
disagree, but I digress); I've got an updated which replaces let bob++ with let
++bob which appears to make it work (and seems backwards based on the man page,
but I digress (again)); though it's having the side effect of not stopping @ 1
port as defined in hardware.conf.
Comment 3 Rob Landry 2004-12-06 15:37:53 EST
addressed in rhr2-0.9-14.9f; eg. fixed in CVS
Comment 4 David Lawrence 2005-01-03 12:04:00 EST
Closing per rlandrys last comment.

Note You need to log in before you can comment on or make changes to this bug.