Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415956 - Automatic time zone update Isuue
Summary: Automatic time zone update Isuue
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-settings-daemon
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Rui Matos
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1420851 1479818
TreeView+ depends on / blocked
 
Reported: 2017-01-24 08:37 UTC by Rajesh Dulhani
Modified: 2020-12-14 08:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-26 12:09:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
var/log/messages output file received from the customer side (4.14 KB, text/plain)
2017-01-24 08:37 UTC, Rajesh Dulhani
no flags Details

Description Rajesh Dulhani 2017-01-24 08:37:30 UTC
Created attachment 1243853 [details]
var/log/messages output file received from the customer side

Description of problem: Customer reported in as time is not getting automatically updated online during the travel

command >> date 

Version-Release number of selected component (if applicable):
coreutils-8.22-15.el7_2.1.x86_64

How reproducible: We cannot reproduce the case at our end as the issue is with the automatic time zone update. We have got the logs of the /var/log/messages from the customer

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: Time should get automatically updated according to the location

Additional info: Attached /var/log/messages received from the customer side.

Comment 1 Kamil Dudka 2017-01-24 09:25:17 UTC
The 'date' command just displays the time using the system time zone (unless overridden by the $TZ environment variable).  According to the log, it is systemd-timedated what changes the time zone.  I am switching the component to systemd, which is the package that installs systemd-timedated.

Comment 2 Lukáš Nykrýn 2017-01-24 09:45:32 UTC
Timedated does not update timezone based on the location. Maybe gnome does?

Comment 4 Florian Müllner 2017-02-02 12:54:56 UTC
(In reply to Lukáš Nykrýn from comment #2)
> Maybe gnome does?

Yes, though it's gnome-settings-daemon rather than gnome-shell which does that.

Comment 5 Bastien Nocera 2017-02-02 16:17:43 UTC
Kalev's the man for the situation.

Comment 6 Rajesh Dulhani 2017-07-25 14:26:00 UTC
Hello Rui,

Can you please update me with the status of this bug , if it will fixed or not. if yes , any update about the same.

Thanks in advane 

--Rdulhani

Comment 12 Red Hat Bugzilla Rules Engine 2017-10-26 12:09:29 UTC
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.