Bug 1415969 - Should update oc scale help info, mentioning more resources
Summary: Should update oc scale help info, mentioning more resources
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Juan Vallejo
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 09:42 UTC by Weihua Meng
Modified: 2017-03-02 22:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-02 22:21:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Weihua Meng 2017-01-24 09:42:35 UTC
Description of problem:
For now, only DC and RC are mentioned in oc scale help, indeed there are more resources can be given new size such as Job and statefulsets, we need to put them in oc scale help

Version-Release number of selected component (if applicable):
openshift v3.5.0.8

How reproducible:
Always

Steps to Reproduce:
1. oc scale -h

Actual results:
# oc scale -h
Set a new size for a deployment or replication controller 

Scale also allows users to specify one or more preconditions for the scale action. If --current-replicas or
--resource-version is specified, it is validated before the scale is attempted, and it is guaranteed that the
precondition holds true when the scale is sent to the server. 

Note that scaling a deployment configuration with no deployments will update the desired replicas in the configuration
template.

Aliases:
scale, resize

Usage:
  oc scale [--resource-version=version] [--current-replicas=count] --replicas=COUNT (-f FILENAME | TYPE NAME) [options]

Examples:
  # Scale replication controller named 'foo' to 3.
  oc scale --replicas=3 replicationcontrollers foo
  
  # If the replication controller named foo's current size is 2, scale foo to 3.
  oc scale --current-replicas=2 --replicas=3 replicationcontrollers foo
  
  # Scale the latest deployment of 'bar'. In case of no deployment, bar's template
  # will be scaled instead.
  oc scale --replicas=10 dc bar

<---snipped--->


Expected results:
all the supported resources should be mentioned, Job, statefulset...

Additional info:

Comment 1 Juan Vallejo 2017-01-31 18:32:45 UTC
Related PR: https://github.com/openshift/origin/pull/12724

Comment 2 Weihua Meng 2017-02-20 05:34:19 UTC
Verified on openshift v3.5.0.31.
Fixed.
Supported resources: ["deployment" "replicaset" "replicationcontroller" "job" "deploymentconfig"]

Comment 3 Troy Dawson 2017-03-02 22:21:46 UTC
Since this bug never reached customers, I am closing it.


Note You need to log in before you can comment on or make changes to this bug.